PRB: Cannot Connect Through Proxy Server that Requires NTLM Authentication (254396)



The information in this article applies to:

  • Microsoft Windows Internet Services (WinInet)

This article was previously published under Q254396

SYMPTOMS

When using WinInet Application Program Interfaces or the Internet Transfer Control to connect to a site through a proxy server that is configured to require Windows NT Challenge/Response authentication (often called NTLM authentication), the request may fail with an error that indicates you cannot connect. When trying to connect to the same site in Internet Explorer with the same proxy settings, the request succeeds.

CAUSE

A keep-alive connection to the proxy is required for the request to succeed. This connection is identified by the "Proxy-Connection: Keep-Alive" header. Absence of this header will cause authentication to fail.

RESOLUTION

To resolve this problem, set the INTERNET_FLAG_KEEP_CONNECTION flag when you call the HttpOpenRequest WinInet API or add the "Proxy-Connection: Keep-Alive" header in the Execute method of Internet Transfer Control.

STATUS

This behavior is by design.

Modification Type:MajorLast Reviewed:6/17/2002
Keywords:kbprb KB254396