Cannot Open Files on Secure Servers (254324)
The information in this article applies to:
- Microsoft Internet Explorer 5.0 for Windows NT 4.0
- Microsoft Internet Explorer 5.0 for Windows 98
- Microsoft Internet Explorer 5.0 for Windows 95
- the operating system: Microsoft Windows 2000
This article was previously published under Q254324 SYMPTOMS
When you attempt to open a file on a secure (HTTPS://) Web site, you may not be prompted whether you want to open the file from its current locations or save it to disk. Instead, a Save As dialog box may appear, prompting you to choose a location to which to save the file.
CAUSE
This behavior can occur if Internet Explorer is configured not to cache encrypted pages to disk. The default is to cache encrypted pages to disk.
RESOLUTION
To resolve this issue:
- On the Tools menu in Internet Explorer, click Internet Options.
- Click the Advanced tab.
- Click to clear the Do not save encrypted pages to disk check box, and then click OK.
WORKAROUND
To work around this issue, follow a link from a web page such as https://website/default.htm and save the file to your local hard disk, and then opening the file locally.
If you type the full path in the address line https://website/filename.pdf you cannot work around the behavior.
STATUS
This behavior is by design.
MORE INFORMATION
Selecting the Do not save encrypted pages to disk check box prevents Internet Explorer from saving any content from secure Web pages to the Temporary Internet Files cache. If Internet Explorer is unable to cache a file, it cannot open it in place, so you must save the file first before you can use it.
Modification Type: | Major | Last Reviewed: | 12/3/2003 |
---|
Keywords: | kbenv kbprb KB254324 |
---|
|