XFOR: Routing Restrictions May Not Work with Some Antivirus Solutions (254214)
The information in this article applies to:
- Microsoft Exchange Server 5.5
This article was previously published under Q254214 SYMPTOMS
Routing restrictions may not work after you install Simple Mail Transfer Protocol (SMTP) antivirus software.
When you install SMTP antivirus software, the installation places the Exchange Server Internet Mail Service behind an antivirus 'firewall,' as illustrated in the following diagram:
(Internet) ----> (SMTP Virus Scanner) ----> (Exchange Server Internet Mail Service)
In this configuration, the routing restrictions, specifically the
options that require a specific IP address or range of IP addresses, may no longer work. NOTE: Routing restrictions are created on the Routing tab of the Internet Mail Service. A routing restriction is a unit of criteria to allow or restrict incoming SMTP mail.
CAUSE
When an Exchange Server computer running the Internet Mail Service is placed behind an SMTP virus scanner or virus firewall, as illustrated in the diagram in the "Symptoms" section of this article, then the Internet Mail Service actually only accepts connections from the antivirus software. Thus, when the Internet Mail Service processes the message, it records the source computer as 127.0.0.1 (the local host), so the Internet Mail Service never sees all of the other Internet IP addresses.
WORKAROUND
To work around this problem, make sure that the first SMTP daemon, the antivirus firewall, is capable of advanced restrictions.
STATUS
This behavior is by design.
Modification Type: | Minor | Last Reviewed: | 4/28/2005 |
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Keywords: | kbprb KB254214 |
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