FIX: Regular Users Cannot Open the VSS Database on Windows 2000-Based Computers (253301)
The information in this article applies to:
- Microsoft Visual SourceSafe for Windows 6.0
This article was previously published under Q253301 SYMPTOMS
If you log in to Visual SourceSafe on a Microsoft Windows 2000-based computer, the following error message appears:
The database does not exist. Please select another.
If you browse to the location of the srcsafe.ini file, select the file, and then click OK, you return to a blank list of available SourceSafe databases.
CAUSE
This behavior occurs because users who are not in the administrator's group have read-only permission to the registry key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SourceSafe.
RESOLUTION
To resolve this problem, use Regedt32 to grant full control
or special access to the registry key.
STATUSMicrosoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.
This bug has been fixed in Microsoft Visual Studio 6.0 Service Pack 5 (SP5).
To download service pack 5, see the Visual Studio Product Updates page on the following Microsoft Web site at:
Modification Type: | Major | Last Reviewed: | 1/26/2006 |
---|
Keywords: | kbBug kbfix kbsetup kbVS600sp5fix KB253301 |
---|
|