You receive error messages when you click Exit, AutoCorrect, or Increase Indent in Word 2000 (252968)



The information in this article applies to:

  • Microsoft Word 2000

This article was previously published under Q252968
For a Microsoft Word 97 version of this article, see 269566.
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you do one of the following:
  • On the Tools menu, you click AutoCorrect.

    -or-
  • On the File menu, you click Exit to quit Microsoft Word.

    -or-
  • On the Formatting toolbar, you click Increase Indent.

    -or-
  • On the Formatting toolbar, you click either Bullets or Numbering.
Microsoft Word may crash with the following error message.

In Microsoft Windows 95, Microsoft Windows 98, or Microsoft Windows Millennium (Me):
This program has performed an illegal operation and will be shut down.

If the problem persists, contact the program vendor.
When you click Details (on Microsoft Windows Millennium Edition, press ALT+D), you receive the following message:
WINWORD caused an invalid page fault in WINWORD.EXE at address.
NOTE: The actual memory address may vary.

-or-

WINWORD caused an invalid page fault in module MSO9.DLL at address.
NOTE: The actual memory address may vary.

In Microsoft Windows NT 4.0:
An application error has occurred and an application error log is being generated.

WINWORD.EXE

Exception: access violation (c0000005, address:c0000005)
In Microsoft Windows 2000:
WINWORD.exe has generated errors and will be closed by Windows. You will need to restart the program.

An error log is being created.
When you view the error log, a report similar to the following appears:
   Microsoft (R) Windows 2000 (TM) Version 5.00 DrWtsn32
   Copyright (C) 1985-1999 Microsoft Corp. All rights reserved.

   Application exception occurred:
           App:  (pid=748)
           When: 3/21/2000 @ 13:00:31.957
           Exception number: c0000005 (access violation)
				
To view the error log in Microsoft Windows 2000, follow these steps:
  1. Click Start, point to Search, and then click For Files or Folders.
  2. In the Search for files or folders named box, type Drwtsn32.log.
  3. Click Search Now.
  4. Right-click the file, and then click Open on the shortcut menu that appears.

    NOTE: The Drwtsn32.log file is located in the following folder by default:

    C:\Documents and Settings\All Users\Documents\DrWatson

In Microsoft Windows XP:
Microsoft Word for Windows has encountered a problem and needs to close. We are sorry for the inconvenience. To see what data this error report contains, click here.
When you click the link, a report similar to the following appears:
Error Signature
AppName: winword.exe    AppVer: 9.0.0.xxxx      ModName: winword.exe
ModVer:  9.0.0xxxx       Offset: xxxxxxxx

Reporting Details
To view technical information about the error report, click here.
				
To view the error log in Windows XP, follow these steps:
  1. Click Start, and then click Search.
  2. In the Search Results dialog box, click All files and folders.
  3. In the All or part of the file name box, type Drwtsn32.log.
  4. Click More advanced options. Click to select the Search hidden files and folders check box if it is not already selected.
  5. Click Search.
  6. Right-click the file, and then click Open on the shortcut menu that appears.

    NOTE: The Drwtsn32.log file is located in the following folder by default:

    C:\Documents and Settings\All Users\Application Data\Microsoft\Dr Watson

CAUSE

This problem can occur when you turn off all of the following options (clear the check boxes):
  • On the Tools menu, click Options. On the Edit tab, the Tabs and backspace set left indent check box is cleared.

    -and-
  • On the Tools menu, click AutoCorrect. All of the check boxes on the AutoCorrect, AutoFormat As You Type, and AutoText tabs are cleared.

WORKAROUND

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To temporarily work around this problem, delete the Word Data key in the Windows registry. To do this, follow these steps:
  1. Quit all Windows programs.
  2. Click Start, and then click Run.
  3. In the Open box, type regedit.
  4. Click OK.
  5. Select the following Windows registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Word\Data

  6. On the Edit menu, click Delete.
  7. Click Yes to the following question in the Confirm Key Delete dialog box:

    Are you sure you want to delete this key?

    In Windows XP, click Yes to the following question in the Confirm Key Delete dialog box:

    Are you sure you want to delete this key and all of its subkeys?

  8. On the Registry menu, click Exit.
NOTE: Deleting the Data subkey resets several options back to the default settings, including the most recently used file list on the File menu and many settings that you customize in the Options dialog box (on the Tools menu, click Options).

RESOLUTION

To resolve this problem, obtain Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a).

To obtain SR-1/SR-1a, click the article number below to view the article in the Microsoft Knowledge Base:

245025 OFF2000: How to Obtain and Install Microsoft Office 2000 Service Release 1/1a (SR-1/SR-1a)


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
This problem was corrected in Microsoft Office 2000 SR-1/SR-1a.

Modification Type:MinorLast Reviewed:10/12/2005
Keywords:kberrmsg kbbug kbfix kbQFE KB252968