Service Packs May Not Be Installed When Run from a Remote Console Client (252367)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 SP5
- Microsoft Windows NT Server 4.0 SP6
- Microsoft Windows NT Server 4.0 SP6a
- Microsoft Windows NT Workstation 4.0 SP5
- Microsoft Windows NT Workstation 4.0 SP6
- Microsoft Windows NT Workstation 4.0 SP6a
This article was previously published under Q252367 SYMPTOMS
If you run an unattended Setup of Microsoft Windows NT 4.0 Service Pack 5 (or Service Pack 6) from a Remote Console client, Update.exe runs but it may not actually update anything. In addition, a "Service Pack Setup Error" error message is displayed in Task Manager. Because graphical user interface (GUI) programs that are started from a Remote Console client run in an invisible desktop, you cannot view the service pack window.
CAUSE
This behavior occurs because the Remote Console server loads the client's registry hive (Ntuser.dat) and sets all environment variables except %USERPROFILE%. The service pack update is unsuccessful if the %USERPROFILE% variable does not exist.
WORKAROUND
To work around this behavior, add the %USERPROFILE% environment variable before you run an unattended service pack update.
NOTE: It does not matter if the variable points to the wrong folder. You can set the path by typing the following commands and running the service pack Setup:
set userprofile=%systemroot%\profiles\default user
update.exe /u /q MORE INFORMATION
Remote Console is included in the Microsoft Windows NT 4.0 Resource Kit. This tool enables a client to start a remote shell running on the server. For more information about Remote Console, refer to the Microsoft Windows NT 4.0 Resource Kit tools documentation.
Modification Type: | Major | Last Reviewed: | 5/14/2003 |
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Keywords: | kbenv kbprb kbsetup KB252367 |
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