XADM: Cannot Perform Backup When Exchange System Manager Is Not Installed (251904)
The information in this article applies to:
- Microsoft Exchange 2000 Server
This article was previously published under Q251904 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you try to perform a backup for a computer running Microsoft Exchange 2000 Server on which the Exchange Server Services are installed but the Exchange System Manager is not, the backup may fail to start or may return an error message, depending on the backup software involved.
CAUSE
This behavior occurs because upon installation, both the Exchange Server Services and Exchange System Manager install files and make changes to the registry that are necessary for a successful backup. When Exchange System Manager is not installed, some of the needed files and registry settings are missing, and the backup fails.
RESOLUTION
Install Exchange System Manager on the server; doing so installs the proper files and adds the registry keys needed for a successful backup.
WORKAROUNDWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk.
The following workaround enables a backup to complete without installing Exchange System Manager:
- Copy the Esebcli2.dll file from the Exchange 2000 CD to the Exchsrvr\Bin folder.
- Add the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\BackupRestore\DLLPaths - Add the following value:
esebcli2 = c:\exchsrvr\bin\esebcli2.dll
STATUSMicrosoft has confirmed that this is a problem in Microsoft Exchange 2000 Server.
Modification Type: | Minor | Last Reviewed: | 4/25/2005 |
---|
Keywords: | kbbug kbnofix KB251904 |
---|
|