Cluster Server cannot start if the Quorum disk space is full (251284)
The information in this article applies to:
- Microsoft Windows Server 2003, Enterprise Edition
- Microsoft Windows Server 2003, Standard Edition
- Microsoft Windows Server 2003, Datacenter Edition for Itanium-based Systems
- Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
- Microsoft Windows Server 2003, Datacenter Edition
- Microsoft Windows 2000 Datacenter Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows NT Server, Enterprise Edition 4.0
- Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
- Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
- Microsoft Windows NT Server, Enterprise Edition 4.0 SP6
- Microsoft Windows NT Server, Enterprise Edition 4.0 SP6a
This article was previously published under Q251284 SYMPTOMS
You may be unable to start Windows Clustering. Also, any combination of the following event messages may be listed in the System Event log: - Event 1021: There is insufficient disk space remaining on the Quorum device. Please free up some space on the Quorum device. If there is no space on the disk for the Quorum Log files, then changes to the cluster registry will be prevented.
- Event 1080: Microsoft Cluster Server could not write file file. The disk may be low on disk space or some other serious condition exists.
- Event 1016: Microsoft Cluster Server failed to obtain a checkpoint from the cluster database for log file file.
- Event 1000: Microsoft Cluster Server suffered an unexpected fatal error at line line of source module module. The error code was: 112.
- Event 1022: There is insufficient space left on the Quorum device. Microsoft Cluster Server cannot start.
- Event 1009: Microsoft Cluster Server could not join an existing cluster and could not form a new cluster. Microsoft Cluster Server has terminated.
- Event 1063: Microsoft Cluster Server was successfully stopped.
CAUSE
This behavior can occur if the disk that contains the Quorum log file does not have any free disk space.
RESOLUTION
To resolve this issue, follow these steps:
- Turn off one of the nodes. For example, turn off Node1.
- On the remaining node (Node2), click Start, point to Programs, point to Administrative Tools, and then click Computer Management.
- Click Device Manager, and then click Show Hidden Devices on the View menu.
- In the right pane, expand the non-Plug and Play drivers, and then double-click the Clusdisk driver.
- On the Driver tab, change the Startup type option from System to Disabled.
- Set the startup value of the ClusDisk device back to System and the ClusSvc service back to Automatic.
- In the right pane, double-click the Cluster service, and then click Disabled in the Startup type box.
- On Node2, click Services in Control Panel, and set the ClusSvc service to disabled.
- Restart Node2. Because the Cluster Disk device driver does not start, the disk drives on the shared SCSI bus appear as regular disk drives to the computer.
- Delete the files on the disk that contains the Quorum log to free space on the disk drive. Do not access any files that might be required by the Cluster service or by shared applications unless it is absolutely necessary.
- Set the startup value of the ClusDisk device back to "System" and the ClusSvc service back to "Automatic."
- Restart the computer. The Cluster Service should start and the shared SCSI disk drives and all other resources should be "owned" by the node that is turned on (Node2).
- Restart the other node (Node1). If it is necessary, you can now move the Quorum log to a disk that has more available free space.
STATUS
This behavior is by design.
MORE INFORMATION
If the Cluster Service on both nodes has stopped, it may be impossible to start the Cluster Service on either node. Until the Cluster Service is started, neither node can "own" the disk drive that contains the Quorum log file. Because neither node can "own" the disk drive, access to the disk drive is not available and therefore files on the disk drive cannot be deleted.
Modification Type: | Major | Last Reviewed: | 8/8/2006 |
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Keywords: | kbnetwork kbprb KB251284 |
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