NetWare Login Script Error Message When Editing User Properties (251180)



The information in this article applies to:

  • Microsoft Windows 2000 Server

This article was previously published under Q251180

SYMPTOMS

When you use the Active Directory Users and Computers snap-in to edit new or existing users, you may receive the following error message:
Windows cannot get the user's Netware login script file because: The RPC server is unavailable.
If you click OK, you can edit the user properties.

CAUSE

This issue can occur if File and Print Services for NetWare (FPNW) was installed before you upgraded the Domain to use Windows 2000. If FPNW was not installed or in use, then an object may have been created in the Active Directory when you upgraded the Microsoft Windows NT 3.51 or 4.0-based Primary Domain Controller (PDC).

RESOLUTION

To resolve this issue, follow these steps:
  1. Using Active Directory Users and Computers MMC, click Advanced Features on the View menu.
  2. Click the System container so that the System container displays its objects and containers in the right pane of MMC.
  3. In the right pane of MMC, locate and right-click MNSEncryptionKey Secret, and then click Delete.
WARNING: If you delete this object, you will need to perform an authoritative restore to recover it. For additional information, click the article numbers below to view the articles in the Microsoft Knowledge Base:

241594 How to Perform an Authoritative Restore to a Domain Controller

216243 The effects on trusts and computer accounts when you authoritatively restore Active Directory

STATUS

Microsoft has confirmed this to be a problem in Microsoft Windows 2000.

MORE INFORMATION


Modification Type:MinorLast Reviewed:6/23/2006
Keywords:kberrmsg kbnetwork kbprb KB251180