Web Pages Are Set for Offline Viewing but Cannot Be Viewed Offline (250803)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Internet Explorer 5.01 for Windows 98 Second Edition
  • Microsoft Internet Explorer 5.0 for Windows 98 Second Edition
  • Microsoft Internet Explorer 5.01 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 1
  • Microsoft Internet Explorer 4.0 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 2000
  • Microsoft Windows 98
  • Microsoft Windows 98 Second Edition

This article was previously published under Q250803

SYMPTOMS

After you make specific Web pages available for offline viewing, you discover that those pages, although they appear to be correctly set, are not actually available offline.

CAUSE

This behavior occurs because some Web sites use "no-cache" or "Pragma: no-cache" headers. If the file cannot be saved to the cache, then it cannot be made available offline.

STATUS

This behavior is by design.

MORE INFORMATION

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

234067 HOWTO: Prevent Caching in Internet Explorer


Steps to Reproduce the Behavior


Internet Explorer 4.0


  1. Start Internet Explorer 4.0.
  2. In the Address toolbar box, type www.hotmail.com and press ENTER.
  3. On the Favorites menu, select Add to Favorites.
  4. Click to select Yes, but only tell me when this page is updated.
  5. Click OK.
  6. Click the Favorites button on the toolbar, and right-click the Hotmail icon. Notice that the shortcut menu has Unsubscribe and Update now options.
  7. On the File menu, click Work Offline.
  8. Click the Hotmail icon in the left pane. A message appears, indicating that the Web page is not available offline.

Internet Explorer 5.0


  1. Start Internet Explorer 5.0.
  2. In the Address toolbar box, type www.hotmail.com and press ENTER.
  3. On the Favorites menu, click Add to Favorites.
  4. Click to select Make available offline.
  5. Click OK and wait for synchronization to finish.
  6. Click the Favorites button on the toolbar. Notice that there is no shortcut arrow over the Hotmail icon in the left pane to indicate that it is available offline.
  7. Right-click the Hotmail icon, and notice that the Make available offline option is selected.
  8. On the File menu, click Work Offline. Notice that the Hotmail icon is unavailable. If you click the icon, a dialog box appears, indicating that the Web page is not available offline.

Modification Type:MinorLast Reviewed:12/21/2004
Keywords:kbprb KB250803