"Invalid command" or "Installation wizard" errors during Setup after the CD key prompt (250343)



The information in this article applies to:

  • Microsoft Visual Studio, Enterprise Edition 6.0
  • Microsoft Visual Basic Learning Edition for Windows 6.0
  • Microsoft Visual Basic Professional Edition for Windows 6.0
  • Microsoft Visual Basic Enterprise Edition for Windows 6.0
  • Microsoft Visual C++, 32-bit Enterprise Edition 6.0
  • Microsoft Visual C++, 32-bit Professional Edition 6.0
  • Microsoft Visual C++, 32-bit Learning Edition 6.0
  • Microsoft Visual InterDev 6.0
  • Microsoft Visual FoxPro for Windows 6.0
  • Microsoft Visual J++ 6.0
  • Microsoft Visual SourceSafe for Windows 6.0

This article was previously published under Q250343

SYMPTOMS

After you start the installation of Visual Studio 6 (or a standalone Visual Studio product), Visual Studio 6 Service Pack 5, or Visual Studio 6 Service Pack 6 on Microsoft Windows NT, on Microsoft Windows 2000, or on Microsoft Windows XP, you may receive one of the following error messages before or after you enter the CD key:
Setup has encountered a problem and needs to close
Installation wizard couldn't find Acme setup
Installation wizard cannot find Acme setup
Setup error 530 invalid command line
Setup Error 530 invalid command option in settings \administrators\localsettings\temp\vs60wiz.exe
Setup error 725 invalid command line
Application Error in VS60wiz.exe
Setup initialization error; there is insufficient memory to run setup
Setup initialization error; there is insufficient disk space to run setup
The specified path does not exist. Check the path and then try again

CAUSE

Setup does not succeed at the Windows NT Virtual DOS Machine (NTVDM) level as installation is handed off to Acmsetup. This is caused by a corrupt 16-bit subsystem.

RESOLUTION

On Windows 2000 platforms, boot into Safe Mode by pressing F8 when prompted at the startup of the system and selecting Safe Mode. Then attempt installation again.

If the installation does not succeed and returns one of the errors listed in the "Symptoms" section of this article, continue with the following steps:
  1. Clear the Temp folder by removing any previous incomplete installations.
    • The default location for the Temp folder on Windows 2000 is C:\Documents and Settings\Profile\Local Settings\Temp C:\Winnt\Temp or, if upgraded from Windows 98, C:\Windows\Temp.
    • The default location for the Temp folder on Windows NT 4 is C:\Temp C:\Winnt\Temp.
    NOTE: To discover the location of your Temp folder: on the Start menu, click Run, type %temp%, and then click OK.

  2. Try to manually start Acmsetup by typing the following command line:

    E:\SETUP\ACMSETUP.EXE /T *.STF /S E:\ /n "" /o "" /k "YYYYYYYYYY" /b1

    where E is the CD-ROM or DVD-ROM drive letter, and YYYYYYYYYY is the CD key for the product (the /k options and its argument should be omitted for Service Pack installations).

    NOTE:The specific *.stf file that is required for the manual command line will vary depending on the specific product you are installing. Search the \Setup folder on the CD-ROM of the product you are installing for the *.stf to use. For example, for Visual Basic 6.0 Professional, use VB98Pro.stf.
If you still cannot install the product by passing the command line manually, continue with the following to repair the NTVDM process.

Nullify any nonstandard settings in the Config.nt and Autoexec.nt files in the system root\System32 folder. To do so, use an REM statement to remark out each entry except the following default entries:

Config.nt

dos=high, umb
device=%SystemRoot%\system32\himem.sys
files=20

Autoexec.nt

lh %SystemRoot%\system32\mscdexnt.exe
lh %SystemRoot%\system32\redir
lh %SystemRoot%\system32\dosx
lh %SystemRoot%\system32\nw16 (only if CSNW is installed)*
lh %SystemRoot%\system32\vwipxspx (only if CSNW is installed)*

* CSNW is Client Services for NetWare

NOTE: Another way to accomplish this is to expand Autoexec.nt_ and Config.nt_ from the Windows NT or Windows 2000 CD-ROM to the SystemRoot\System32 folder:
  • To expand a single compressed file, use the Expand.exe program. This program is located on the Windows CD-ROM in the I386 folder.
  • To expand the required files:
    1. Insert the Windows CD-ROM into the CD-ROM or DVD-ROM drive.
    2. At the command prompt, type the following, and then press ENTER:

      C:\WINDOWS\System32\Autoexec.nt

    3. At the command prompt, type the following, and then press ENTER:

      EXPAND X:\i386\Config.NT_ C:\WINDOWS\System32\Config.nt

    4. Restart the computer and try to install the product again.

MORE INFORMATION

Setup.exe passes the following to Acmsetup.exe:

X:\disk1\SETUP\ACMSETUP.EXE /T VS98Ent.STF /S E:\ /n "" /o "" /k "YYYYYYYYYY" /b 1

where:
  • X is your path to Acmsetup.exe
  • E is the CD-ROM or DVD-ROM drive letter
  • YYYYYYYYYY is the CD key
You can verify the command line switches by running Setup on a computer that you know is operating correctly, thereby creating a setup log.

Your specific *.stf file will vary depending on the specific product you are installing. Search the \Setup folder of the product you are installing for the *.stf to use. For example, for Visual Basic 6.0 Professional, it is VB98Pro.stf

Generating a Log File

You can tell the Acme part of Setup to generate a log file. To do this, start Setup with the following command:

X:\setup /gc path\file name

where X is the location of the CD-ROM or DVD-ROM drive, and path\file name is the path and file name for the log file. The path and file name must be in 8.3 short name format and must not be in quotation marks.

REFERENCES

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

196453 Troubleshooting NTVDM and WOW startup errors

220155 Troubleshooting NTVDM and WOW startup errors

165214 Troubleshooting MS-DOS-based programs in Windows

222975 Cannot install program using its Setup utility

260513 An error occurs when you install Visual Studio products

192392 How to troubleshoot Visual Studio 6.0 Setup

192731 BUG: Hang or application error in Setup


Modification Type:MajorLast Reviewed:5/2/2006
Keywords:kbprb KB250343