Computer Hangs When You Add Input Locales in the Regional Options Tool (250298)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP4
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP5
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Workstation 4.0 SP5
  • Microsoft Windows NT Workstation 4.0 SP6
  • Microsoft Windows NT Workstation 4.0 SP6a
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Server 4.0 SP6a
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6a

This article was previously published under Q250298

SYMPTOMS

When you configure settings on the Input Locales tab of the Regional Options tool, your computer may stop responding (hang). You may receive the following error message:
An error occurred while Windows was working with the Control Panel file:

C:\WINNT\System32\intl.cpl

CAUSE

This issue can occur if you use your keyboard to add a locale.

NOTE: When the Intl.cpl file causes an exception error, Dr. Watson, or the default debug tool, does not trap the exception error because the error is handled by the Control.exe file.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
   Date        Time         Size File name     Platform
   -------------------------------------------------------------
   12/02/1999  11:47a    166,160 gdi32.dll     x86
   12/02/1999  11:47a    326,416 user32.dll    x86
   11/02/1999  11:56a  1,250,896 win32k.sys    x86
   12/02/1999  11:47a    175,376 winsrv.dll    x86

   12/02/1999  11:46a    307,984 gdi32.dll     Alpha
   12/02/1999  11:46a    577,296 user32.dll    Alpha
   11/02/1999  11:55a  2,049,904 win32k.sys    Alpha
   12/02/1999  11:46a    314,128 winsrv.dll    Alpha
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kberrmsg kbfix kbui KB250298