NetSonic Version 2.5 Results in a Continuous Restart and the Uninstaller Does Not Work (250184)



The information in this article applies to:

  • Microsoft Windows Millennium Edition

This article was previously published under Q250184
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

SYMPTOMS

After you install NetSonic version 2.5 on a computer that is running Windows Millennium Edition, and then you restart the computer, NetSonic continuously generates the following error message:
NetSonic Alert!

You must restart your system for NetSonic to operate correctly. Do you want to restart your computer now?
If you click No, the computer continues to function normally. If you click Yes, the computer restarts, and then NetSonic generates the same error message. If you try to uninstall the program by clicking the Add/Remove programs icon in Control Panel, you receive the following error message:
NetSonic Internet Accelerator

Please Restart Your Computer. You have performed some action that requires you to reboot. Please restart your computer and then you may uninstall NetSonic.
You can then click Uninstall, or Restart. If you click Restart, you may receive the same NetSonic alert mentioned at the beginning of this article. Following the instructions presented by NetSonic results in continuous restarts.

CAUSE

The NetSonic version 2.5 schedules an overwrite of the Wsock32.dll file, which is located in the x:\Windows\System folder, by way of an entry in the Wininit.ini file. However, because of the System File Protection component that is used by Windows Me, this file is protected, and is automatically restored.

NetSonic version 2.5 adds the Webmain.exe program into the Startup folder. During the reboot process, Webmain.exe tries to locate its version of the Wsock32.dll file before it will work. When it locates the Windows version of the file, it repeats the Wsock32.dll overwrite by way of the Wininit.ini file, which prompts you to restart your computer.

RESOLUTION

Please contact the program manufacturer for a resolution to this issue.

WORKAROUND

To remove the software from your system, follow these steps:
  1. When you are prompted to restart your computer, click No.
  2. Click Start, click Run, type msconfig, and then click OK.
  3. On the General tab of the System Configuration Utility tool, choose the Selective Startup option.
  4. Click to clear the Load Startup Group Items option.
  5. Click OK, and then restart the computer when you are prompted to do so.
  6. After restarting the computer, remove the program by clicking Add/Remove programs in Control Panel.
  7. After NetSonic is removed, restart your computer, and then run msconfig again to change the setting back to its original state.

MORE INFORMATION

If you are not able to uninstall NetSonic version 2.5 by following the steps in the "Workaround" section, you may be able to uninstall NetSonic version 2.5 while in Safe mode. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

273738 How to Troubleshoot Windows Millennium Edition Startup Problems

Refer to the "How to Start Windows Me in Safe Mode" section of Q273738.

You can also use the System Restore Utility tool in Safe mode to restore the computer to a time prior to the installation of NetSonic version 2.5. For additional information, click the article number below to view the article in the Microsoft Knowledge Base:

267951 Description of the System Restore Utility in Windows ME

If you try to start the System Restore Utility tool in Normal mode to resolve this issue, you may receive the following error message:
System Restore cannot run until you restart the computer. Please restart the computer, and then run System Restore again.
The System Restore Utility tool produces this error if it finds the presence of the Wininit.ini file in the Windows directory in Normal mode. The System Restore Utility tool should work as expected in Safe mode.

Modification Type:MinorLast Reviewed:1/14/2006
Keywords:kb3rdparty kbenv kbprb KB250184