PRB: MSMQ Exchange Server Connector Removes E-Mail Message from Queue (249195)
The information in this article applies to:
- Microsoft Message Queue Server (MSMQ) 1.0
This article was previously published under Q249195 SYMPTOMS
When you send an e-mail message from a computer running Microsoft Exchange Server to a Microsoft Message Queue Server (MSMQ) message queue, the MSMQ Exchange Server connector removes the e-mail message.
CAUSE
This problem usually occurs when you use a queue for both inbound and outbound MSMQ Exchange Server connector e-mail messages. When you use MSMQ Exchange Server connector queues, use a queue for either inbound or outbound e-mail messages only, not for both.
When an e-mail message arrives in an outbound queue, the MSMQ Exchange Server connector always attempts to send the message through Exchange Server. If the e-mail message is incorrectly formatted, the MSMQ Exchange Server connector sends a non-deliverable receipt (NDR) to the Exchange Server administrator.
RESOLUTION
Set up an inbound queue and a separate outbound queue.
STATUS
This behavior is by design.
MORE INFORMATIONSteps to Reproduce Behavior
1. Set up a MSMQ Exchange Server connector instance to monitor an inbound queue.
2. Create a MSMQ custom recipient in Exchange Server to go to this queue.
3. Send a message to the custom recipient.
Modification Type: | Major | Last Reviewed: | 5/27/2000 |
---|
Keywords: | kbprb KB249195 |
---|
|