Active Directory Replication May Not Work Using Windows NT 4.0 Server Manager in Windows 2000 Domain (249140)
The information in this article applies to:
- Microsoft Windows 2000 Server
- Microsoft Windows 2000 Advanced Server
- Microsoft Windows 2000 Professional
- Microsoft Windows NT Server 4.0
- Microsoft Windows NT Server 4.0 SP1
- Microsoft Windows NT Server 4.0 SP2
- Microsoft Windows NT Server 4.0 SP3
- Microsoft Windows NT Server 4.0 SP4
- Microsoft Windows NT Server 4.0 SP5
- Microsoft Windows NT Server 4.0 SP6
- Microsoft Windows NT Server 4.0 SP6a
This article was previously published under Q249140 SYMPTOMS
You can use Server Manager (Srvmgr.exe) to synchronize the user account database of a Windows NT 4.0 or Windows 2000 domain. If you use the Windows NT 4.0 version of Server Manager to trigger synchronization in a domain with a Windows 2000 primary domain controller (PDC), Active Directory replication may not work.
You can use Replmon.exe to search for all domain controllers with unsuccessful replication. An example output follows:
Active Directory Replication Domain Controller Replication Failure
Output Printed at 12/3/1999 6:03:41 AM
Below are the replication failures detected on Domain Controllers
for this domain:
Domain Controller Name: DCNAME00
Directory Partition: DC=domain,DC=corp
Replication Partner: Domain\DCNAME01
Failure Code: 5
Failure Reason: Access is denied.
Additionally, the Internet Service Manager (ISM) service on the server may not start and may display an SEC_E_LOGON_DENIED error code.
CAUSE
This behavior occurs because the synchronization request generated by the Windows NT 4.0 version of Server Manager triggers a computer account password reset operation. After the password is changed, the PDC cannot establish a secure replication channel between itself and its partner domain controllers.
RESOLUTION
A new version of Srvmgr.exe is available for use in mixed-mode domains, with Windows NT 4.0 and Windows 2000 domain controllers. This version of Srvmgr.exe checks to see if the PDC is a Windows 2000 domain controller. If it is a Windows 2000 domain controller, the password reset operation is not triggered.
A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site: NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.
The English-language version of this fix should have the following file attributes or later:
Date Time Size File name Platform
-----------------------------------------------------
12/23/1999 12:50p 211,216 Srvmgr.exe I386
12/23/1999 12:50p 305,936 Srvmgr.exe Alpha
STATUSMicrosoft has confirmed that this is a problem in Windows NT 4.0.
Modification Type: | Minor | Last Reviewed: | 9/26/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbnetwork KB249140 |
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