Error Message: Ping Caused an Invalid Page Fault in Module Unknown (249005)



The information in this article applies to:

  • Microsoft Windows 98

This article was previously published under Q249005
If this article does not describe the error message that you are receiving, view the following Microsoft Knowledge Base article to view more articles that describe error messages:

315854 Windows 98 and Windows Me Error Message Resource Center

SYMPTOMS

When you use the Ping utility to ping a host name, you may receive the following error message:
Ping caused an Invalid Page Fault in Module Unknown.
When you use the Ping utility to ping by IP address, Ping may work as expected.

CAUSE

This issue may occur if you have IBM Personal Communications software installed, and you uninstall and reinstall Dial-Up Networking without first removing the IBM software.

RESOLUTION

To resolve this issue:
  1. Uninstall the IBM Personal Communications software. For information about how to uninstall IBM Personal Communications, please refer to the documentation included with the program, or contact IBM.
  2. After you have successfully removed IBM Personal Communications, try to ping a host name. For example, try to ping an Internet site (such as www.yahoo.com). If you can now ping by host name, continue with step 3. If you cannot ping by host name, remove and reinstall Dial-Up Networking, Transmission Control Protocol/Internet Protocol (TCP/IP),and your adapter driver.

    For additional information about removing and reinstalling Dial-Up Networking and TCP/IP, click the article number below to view the article in the Microsoft Knowledge Base:

    181599 How to Remove and Reinstall Dial-Up Networking and TCP/IP Files

    For information about uninstalling and reinstalling your network adapter driver, you may need to see the documentation included with your device or visit your hardware manufacturer's web site. After you are able to ping by host name, continue to the next step.
  3. Reinstall the IBM Personal Communications software.
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

Modification Type:MinorLast Reviewed:12/20/2004
Keywords:kb3rdparty kberrmsg kbInvalidPageFault kbprb KB249005