OFF2000: Windows Stops Responding When You Log on to a Terminal Server Computer (248658)



The information in this article applies to:

  • Microsoft Office 97 for Windows
  • Microsoft Office 2000 Developer
  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professional
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Standard
  • the operating system: Microsoft Windows NT 4.0

This article was previously published under Q248658
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you log on to a Terminal Server computer either from a client workstation by using the Terminal Server Client or directly from the console, Windows may appear to stop responding (displaying an hourglass) for several minutes after the desktop appears, and you cannot click the Start menu or double-click any icon on the desktop until the hourglass disappears.

Over time, this problem may become noticeably worse and may lead to an eventual crash of the Terminal Server computer.

CAUSE

When Windows loads the desktop, it scans the Windows registry. If the TypeLib key (HKEY_CLASSES_ROOT\TypeLib) in the Windows registry is inflated, it appears to slow down or stop Windows while the registry is scanned.

When you run any of the Microsoft Office 97 or Microsoft Office 2000 programs, the following new folders are created in the user session Temp folder:
  • Excel9.0
  • Ppt9.0
  • Word8.0
  • Vbe
The first time that you insert a control into a document or UserForm, the Office program creates an .exd file for that control in the appropriate folder. After a program creates the .exd file for a specific control, it takes less time to insert the same control again. This is because the .exd file caches information for the control. However, at the same time, a unique class ID registry entry is made in the Windows registry for this .exd file.

When each user logs off the Windows Terminal Server computer, their session Temp folder is also deleted. The specified folders described earlier in this article, along with the .exd files created in those folders, are deleted when this occurs. However, the registry entries created still remain. Over time, as the same or subsequent users log on and use form controls on the Windows Terminal Server computer, the Windows registry (HKEY_CLASSES_ROOT\TypeLib) increases in size enough to exhibit the behavior described in the "Symptoms" section of this article.

For additional information about why .exd files are created and their use in Microsoft Office programs, click the article number below to view the article in the Microsoft Knowledge Base:

199830 OFF2000: EXD Files Are Created When You Insert Controls

RESOLUTION

Method 1

To resolve this issue with minimal problems, you must back up all user data stored on the server, format the server, and then reinstall the Windows Terminal Server and all programs. Then you can restore all user data from your backup.

NOTE: This is the only method supported by Microsoft Technical Support.

NOTE: Please see the "Workaround" section later in this article for steps to prevent this problem from recurring.

Method 2

WARNING: The following possible method is given only as an alternative to the supported Method 1. It is not suggested that these steps be used, and any problems experienced as a result of performing these steps are to be taken at your own risk. THIS METHOD IS NOT SUPPORTED BY MICROSOFT TECHNICAL SUPPORT. You may still have to resort to the solution given in Method 1 to completely resolve this problem.

WARNING: USE THE FOLLOWING AT YOUR OWN RISK.

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this problem, you need a second computer. Follow these steps:
  1. On a separate computer (designated in these steps as Machine-B), install Windows NT 4.0 Terminal Server Edition.
  2. On Machine-B, install each program exactly as it is installed on the original computer that is exhibiting the problems described in the "Symptoms" section of this article (designated in these steps as Machine-A).NOTE: It is best for Machine-A and Machine-B to be 100 percent identical in hardware and drive configurations.

  3. On Machine-B, open the Windows Registry and export the TypeLib key:
    1. On the Windows Start menu, click Run.
    2. Type Regedit and then click OK.
    3. Browse to and select the following key:

      HKEY_CLASSES_ROOT\TypeLib

    4. On the Registry menu, click Export Registry File, give the file a name, and save it to a floppy disk.
    5. Quit the Registry Editor.
  4. On Machine-A, open the Windows Registry and delete the TypeLib key:
    1. On the Windows Start menu, click Run.
    2. Type Regedit and then click OK.
    3. Browse to and select the following key:

      HKEY_CLASSES_ROOT\TypeLib

    4. On the Edit menu, click Delete.
    5. Quit the Registry Editor.
  5. Place the floppy disk created in step 3-d into the floppy disk drive of Machine-A.
  6. Browse to and double-click the Registry file to import it into the Windows Registry of Machine-A.
As a result, the TypeLib key on Machine-A will be updated to reflect the clean state as seen on Machine-B. The problem described in the "Symptoms" section should no longer be seen.

NOTE: Please see the "Workaround" section later in this article for steps to prevent this problem from recurring.

WORKAROUND

To prevent this problem, you can use flat temporary directories on your Windows NT Server 4.0 Terminal Server Edition.

By default, flat temporary directories are turned off (disabled). This means that the system creates a subdirectory under the directory specified by the TEMP and TMP environment variables that corresponds to the hexadecimal value of each user's logon ID.

By using FLATTEMP to enable flat temporary directories, the system no longer creates subdirectories under the directory specified by the user's TEMP environment variable. This could result in users using the same directory to store temporary files. If flat temporary directories are enabled, make sure each user is using his or her own specific temporary directory by setting the TEMP and TMP environment variables in the System icon in Control Panel.

For additional information about FLATTEMP, click the article number below to view the article in the Microsoft Knowledge Base:

186516 Terminal Server Commands: FLATTEMP

STATUS

Microsoft has confirmed that this is a problem in Microsoft Office 2000 and Microsoft Office 97.

MORE INFORMATION

For additional information about this and related problems, click the article numbers below to view the articles in the Microsoft Knowledge Base:

189119 UserEnv Returns Corrupted Profile for All Failures Including RSL Exceeded

223492 Registry Size Increases After Installing Outlook Express 5


Modification Type:MajorLast Reviewed:6/11/2002
Keywords:kbbug kbenv kbgpf kbprb kbui KB248658