SMS: Windows 95/98 Client Hangs During Hardware Inventory (248362)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
- Microsoft Systems Management Server 2.0 SP1
This article was previously published under Q248362 SYMPTOMS
A client that is running Microsoft Windows 95 or Microsoft Windows 98 may seem to stop responding (hang) for up to two minutes. This behavior occurs only on some portable computers on which the floppy disk drive is not connected to the computer during hardware inventory.
CAUSE
During Systems Management Server (SMS) hardware inventory, the Win32_Logicaldisk WMI class is enumerated to return logical disk information for removable disk drives, CD-ROM drives, hard disks, and connected network drives. On some types of portable computers, you can remove the floppy disk drive, but the computer's BIOS still registers (or "spoofs") its existence. In Windows 95/Windows 98, the floppy disk drive icon still appears in My Computer when no device is actually attached. Opening the disk drive icon also causes the symptom described in this article to occur until the device times out.
RESOLUTIONTo resolve this problem, obtain the latest service pack for Systems Management Server version 2.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
236325 How to Obtain the Latest Systems Management Server 2.0 Service Pack
WORKAROUND
To work around this behavior, disable the enumeration of the Win32_LogicalDisk class in the Sms_def.mof file for the site. For information about how to do this, see chapter 10 of the Microsoft Systems Management Server Administrator's Guide. NOTE: If you have applied the hotfix that is described in the following Microsoft Knowledge Base article, the Win32_LogicalDisk class has been replaced by SMS_LogicalDisk:
232653 SMSCliToknAcct Locked Out When Hardware Inventory Is Enabled
Follow the same steps as described in chapter 10 of the Administrator's Guide to disabled enumeration of the SMS_LogicalDisk class.
STATUS
Microsoft has confirmed this to be a problem in Systems Management Server version 2.0 This problem was first corrected in Systems Management Server version 2.0 Service Pack 2..
Modification Type: | Major | Last Reviewed: | 4/7/2006 |
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Keywords: | kbQFE KBHotfixServer kbBug kbfix kbInventory kbsms200sp2fix kbWBEM KB248362 |
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