InstallShield Stops Responding When You Try to Install 32-Bit Programs (247925)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Workstation 4.0

This article was previously published under Q247925

SYMPTOMS

When you try to install 32-bit programs using InstallShield (Setup.exe), InstallShield may stop responding (hang).

CAUSE

This behavior can occur when the Microsoft Windows NT 4.0 virtual DOS machine (VDM) files are corrupted.

RESOLUTION

To resolve this behavior, rename the following files by using the .old file name extension at a command prompt, expand the original files from your Windows NT 4.0 CD-ROM, and then reapply the latest Windows NT 4.0 service pack:

Autoexec.nt 
Config.nt 
Vdmredir.dll(MS-DOS redirector driver)
Krnl386.exe(16-bit kernel)
User.exe(16-bit subsystem file)
Gdi.exe(16-bit and 32-bit handles video calls)
Wowexec.exe(Win16-bit subsystem)
Ntvdm.exe(MS-DOS subsystem)
Ntio.sys(I/O driver)
Ntdos.sys(MS-DOS driver)
Redir.exe(network redirector)

Modification Type:MajorLast Reviewed:8/27/2002
Keywords:kbprb KB247925