Cluster Administrator May Stop Responding After Creating a New IIS Server Instance (247763)



The information in this article applies to:

  • Microsoft Internet Information Server 4.0

This article was previously published under Q247763

SYMPTOMS

Microsoft Cluster Administrator may stop responding when adding a new Microsoft Internet Information Server (IIS) Instance after Windows NT 4.0 Service Pack 4 has been applied to the cluster nodes.

CAUSE

The Cluster Administrator stops responding (Clusadmin.exe) because of a Second Chance (non-recoverable) Access Violation in the Cluster Resource Monitor (Resrcmon.exe). The Access Violation in Resrcmon.exe causes Remote Procedure Call (RPC) failures in Clusadmin.exe while trying to execute code in Resrcmon.exe. The RPC failures causes Clusadmin.exe to stop responding as Clusadmin.exe continually tries to execute code in the failing Resrcmon.exe.

The Second Chance Access Violation occurs when the IIS 4.0 resource monitor extension (Clusiis4.dll) attempts to build the meta data path to the new site on the node so that all the property changes can be remotely transferred to nodes in the cluster per the Windows NT Service Pack 4. This design change is described in the following Knowledge Base article:

224293 IIS Cluster Admin. Extension Cannot Remotely Administer IIS in a Cluster

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem. This fix may receive additional testing. Therefore, if you are not severely affected by this problem, Microsoft recommends that you wait for the next Windows NT service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The typical support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English version of this fix should have the following file attributes or later:
   Date        Time    Version      Size    File name     Platform
   ---------------------------------------------------------------
   12/03/1999  04:57p  4.2.734.1    33,872  clusiis4.dll  i386
   12/03/1999  04:53p  4.2.734.1    53,520  clusiis4.dll  alpha
				

STATUS

Microsoft has confirmed that this is a problem in Internet Information Server 4.0.

MORE INFORMATION


Modification Type:MinorLast Reviewed:10/6/2005
Keywords:kbHotfixServer kbQFE kbBug kbfix kbQFE KB247763