SMS: Discovery Data Manager Fails to Enumerate Sites (247546)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
This article was previously published under Q247546 SYMPTOMS
A Systems Management Server site receives the following error message (Msg ID 679) every few minutes from the Discovery Data Manager:
Failed to enumerate sites
CAUSE
The SMS Service account listed in the SMSDATA table of the Systems Management Server database does not match the service account with which the SMS_EXECUTIVE is started (as listed under Services in Control Panel).
When a Systems Management Server component connects to an SQL database, Systems Management Server checks whether the connection is being made by the SMS Service account. If not, Systems Management Server checks permissions and excludes sites from the query of the Sites table based on explicit permissions (provider security). In this case, Discovery Data Manager (DDM) is logged on with an account name that does not match the ServiceAccountName entry in the SMSDATA table. As a result, the query to find all sites returns no rows, causing DDM to malfunction and the error message above to be displayed.
WORKAROUND
To work around this behavior, perform a site reset by running SMS Setup at the Site Server, and respecify the SMS Service Account in the DomainName\ServiceAccountName format.
For example:
It may take several minutes after the site reset is complete before the information is actually updated.
Modification Type: | Minor | Last Reviewed: | 6/14/2005 |
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Keywords: | kbDatabase kbDiscovery kbMMC kbprb kbQuery kbSecurity kbServer kbsetup kbsms200 kbsmsProvider kbStatSum KB247546 |
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