IBM PCOM 5250 Fails on Windows 95/98 after a 3270/FMI Session Is Closed (247332)



The information in this article applies to:

  • Microsoft SNA Server 3.0 SP1
  • Microsoft SNA Server 3.0 SP2
  • Microsoft SNA Server 3.0 SP3
  • Microsoft SNA Server 3.0 SP4
  • Microsoft SNA Server 4.0
  • Microsoft SNA Server 4.0 SP1
  • Microsoft SNA Server 4.0 SP2
  • Microsoft SNA Server 4.0 SP3

This article was previously published under Q247332

SYMPTOMS

When you use IBM Personal Communications (version 4.3) with the SNA 4.0 Windows 95/98 client software or with the SNA 4.0 Windows NT client software, a 5250 session stops responding or fails with a page fault after a 3270 session is closed. For example:
PCSCM caused an invalid page fault in module WAPPC32.DLL at 015f:6340e645
The offset may vary depending on the version of the SNA Windows 95/98 or Windows NT client software being used.

CAUSE

If an application supports both a 3270/FMI session and an APPC or CPIC conversation from the same process, and closes the 3270/FMI session by calling the sbputerm() function, the SNA client incorrectly frees the SNADMOD client code while the APPC/CPIC application is still active.

RESOLUTION

To resolve this problem, obtain the latest service pack for SNA Server 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack


WORKAROUND

To work around this problem, do not close the 3270 session if an APPC conversation is still active, or close the APPC conversation before the 3270 session is closed.

STATUS

Microsoft has confirmed that this is a problem in Microsoft SNA Server version 3.0, 4.0, 4.0 SP1, 4.0 SP2 and 4.0 SP3.

This problem was first corrected in SNA Server 4.0 Service Pack 4.

Modification Type:MinorLast Reviewed:7/16/2004
Keywords:kbbug kbfix kbQFE kbSNA400PreSP4fix kbSNA400sp4fix KB247332