SMS: Executive Service Performance Is Severely Affected if It Is Unable to Write to a Log File (247229)
The information in this article applies to:
- Microsoft Systems Management Server 2.0
This article was previously published under Q247229 SYMPTOMS
When logging is enabled for a Microsoft Systems Management Server component that is implemented as a thread of the SMS Executive service, the service must be able to obtain write access to the log file. If the SMS Executive service cannot open the output file to write the logging information, its performance is severely affected.
CAUSE
The component enters a loop and continuously attempts to open the file. This behavior dramatically slows the SMS Executive service: It takes five seconds for the loop to time out for every entry that a given component attempts to log.
WORKAROUND
Ensure that the Systems Management Server service account has full access to the directory where the Systems Management Server log files are created. By default, this is the \Sms\Logs directory.
Modification Type: | Minor | Last Reviewed: | 1/14/2006 |
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Keywords: | kbConfig kbprb KB247229 |
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