Event ID 60 occurs with SNA Server after updating to Windows NT 4.0 SP4 or Later (246830)
The information in this article applies to:
- Microsoft SNA Server 3.0
- Microsoft SNA Server 3.0 SP1
- Microsoft SNA Server 3.0 SP2
- Microsoft SNA Server 3.0 SP3
- Microsoft SNA Server 3.0 SP4
- Microsoft SNA Server 4.0
- Microsoft SNA Server 4.0 SP1
- Microsoft SNA Server 4.0 SP2
- Microsoft SNA Server 4.0 SP3
- Microsoft SNA Server 4.0 SP4
This article was previously published under Q246830 Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base: 256986 Description of the Microsoft Windows Registry SYMPTOMS
When SNA Server is unable to locate the Invokable Auto-started TP in the SNA Server Subdomain, an event ID 60 occurs in the Application Event Viewer. For example:
Event ID: 60
Source: SNA Server
Description: Failed to invoke APPC TP (HEX TP NAME) (ASCII TP NAME), local LU = (Local APPC LU), sense data = 84c0000
Event ID: 730
Source: SNA Server
Description: The SNA Server was unable to locate an invokable TP (Name), APPC LU Alias (Local APPC LU), Workstation name: (null).
This Invokable TP is written as a service and is started by the Service Control Manager under Windows NT. The SNA Server service attempts to locate the service by the TP Name included in the ALLOCATE received from the Host or AS/400. When the status of the TP service is verified, it is either not registered or it is in an inactive state. SNA Server logs the event ID 60 after the timeout has been exceeded. The timeout setting is a configurable setting located in the properties of the Local LU Advanced settings. The default is 60 seconds.
CAUSE
This can be caused by the TP starting before the SNA Server SnaBase service has finished initializing.
This problem can also occur when you upgrade from Windows NT Server 4.0 Service Pack 3 to Service Pack 4 or later.
For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
197286
Third-party services may fail to start after upgrade to Windows NT SP4
Service Pack 4 changes the order of how the services are loaded for all Windows NT services. Because the TP may not use the following resolution, the TP is loaded before the initialization of SNABASE. Therefore, the TP does not successfully register in the SNA Service Table. See the "More Information" section of this article for information concerning the importance of the SNA Service Table.
RESOLUTION
To correct this issue, perform the following steps:
Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk. - Start Registry Editor (Regedt32.exe).
- Locate the following key in the registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<TP NAME>
- On the Edit menu, click Add Value, and then add the following registry value:
Value Name: DependOnService
Data Type: REG_MULTI_SZ
Value: SnaBase
- Quit Registry Editor.
By adding this entry, the Service Control Manager verifies that the SnaBase service has successfully started before starting the TP. This ensures that the TP will register properly with the ST, giving the proper location and active state information.
MORE INFORMATION
All SNA Server services and resources are required to register themselves in the SNA Service Table(ST). Because the ST is a dynamic memory allocated table, the SNA Server service (and SNA clients) locates the needed services through the ST within that current SNA Server Subdomain. In this case, the Auto-started Invokable TP will register in the ST. With an Invoking TP, an ALLOCATE or MC_ALLOCATE is received by the SNA Server outbound from the HOST. In the ALLOCATE, the TP name resides ( for further information on the ALLOCATE review the SNA Server SDK included with SNA Server). The SNA Server service checks the TP name in the ALLOCATE, finds a match in the Service Table, and verifies that it is in an active state (the Invokable TP has issued a RECEIVE_ALLOCATE). Once this is found and verified, the conversation will continue.
Modification Type: | Major | Last Reviewed: | 8/17/2004 |
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Keywords: | kbsnaonly kbprb KB246830 |
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