Error Message: Unable to Initialize Windows Socket Interface Code (246727)



The information in this article applies to:

  • Microsoft Internet Explorer 5.01 for Windows 98
  • Microsoft Internet Explorer 5.0 for Windows 98
  • Microsoft Internet Explorer 4.01 for Windows 98 SP 2
  • Microsoft Internet Explorer 5.01 for Windows 95
  • Microsoft Internet Explorer 5.0 for Windows 95
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 1
  • Microsoft Internet Explorer 4.01 for Windows 95 SP 2
  • Microsoft Internet Explorer 4.0 for Windows 95

This article was previously published under Q246727
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you attempt to browse Internet sites with Internet Explorer, you may receive the following error message:
The page cannot be displayed.
Also, when you use the ping command at a command prompt, you may receive the following error message:
Unable to initialize Windows socket interface, error code 6
These error messages may occur even if you are able to successfully connect to your Internet service provider (ISP) by using Dial-Up Networking.

CAUSE

This behavior can occur if the following registry key is missing or corrupted:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To resolve this issue:
  1. Start Registry Editor (Regedit.exe).
  2. Locate and click the following registry key:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Winsock2

  3. Export the Winsock2 key for backup purposes, and then delete the Winsock2 key by clicking it and then pressing DELETE. Confirm that you want to delete the key, and then quit Registry Editor.
  4. Uninstall Dial-Up Networking:
    1. Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
    2. Click the Windows Setup tab.
    3. Click Communications, click Details, and then click to clear the Dial-Up Networking check box.
    4. Click OK, and then click OK.
  5. After you uninstall Dial-Up Networking, restart the computer.
  6. Reinstall Dial-Up Networking:
    1. Click Start, point to Settings, click Control Panel, and then double-click Add/Remove Programs.
    2. Click the Windows Setup tab.
    3. Click Communications, click Details, and then click to select the Dial-Up Networking check box.
    4. Click OK, and then click OK.
  7. After you reinstall Dial-Up Networking, restart the computer.
This rebuilds the Winsock2 key in the registry.

Modification Type:MajorLast Reviewed:12/8/2003
Keywords:kberrmsg kbprb KB246727