PRB: Wait Action Doesn't Wait For Time Specified in Routing Map (246713)



The information in this article applies to:

  • Microsoft Exchange Server 5.5
  • Microsoft Exchange Server 5.5 SP1
  • Microsoft Exchange Server 5.5 SP2
  • Microsoft Exchange Server 5.5 SP3

This article was previously published under Q246713

SYMPTOMS

You can configure a Microsoft Exchange Server Routing Object application to wait for X minutes before it executes the next line of the code. However, you might find that the application doesn't actually wait for X minutes. For example, for the following setting in a Routing Map,
......
100  Wait         0   X
200  DoSomething  2
.......
				
the application may wait longer than X minutes.

CAUSE

The Routing Engine (or the Routing Object) was built on the Exchange Event Service. The Event Service is implemented as a Microsoft Windows NT service that receives notifications about the state of folder items from server-based folders.

The Event Service fires events when an item is added, changed, or deleted in a folder, or according to time intervals. The time interval can be set from the Event Scripting Agent. The time interval must always be a multiplication of 15 minutes, such as 0 minutes, 15 minutes, 30 minutes, and so on. If you set the waiting time to be in the middle of an interval, for example 20 minutes, then the application actually waits for 30 minutes.

MORE INFORMATION

The Wait action actually acts as "wait for Either a response OR a specified time to pass (X minutes in this sample)".

For example, if an Approval or Rejection is received before the timeout, the next action, DoSomething, is executed immediately. It does not wait for X minutes.

REFERENCES

You can find more information on how to set time intervals for Microsoft Exchange Server Scripting Agents, under the following topic on the Microsoft Developer Network, Platform SDK documentation:

Configuring Events and Actions

Modification Type:MinorLast Reviewed:3/4/2004
Keywords:kbMsg kbprb KB246713