Error Message: No Client Applications Have Been Added to the Server for Installation to Client Computers... (246357)



The information in this article applies to:

  • Microsoft BackOffice Small Business Server 4.0
  • Microsoft BackOffice Small Business Server 4.5

This article was previously published under Q246357
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you try to add software to a computer from the Small Business Server (SBS) console after you upgrade to SBS 4.5, you may receive the following error message:
Set Up Computer Wizard
No client applications have been added to the server for installation to Client computers. Copy them to the server using Add/Remove Programs, and then click Add Software to a Computer.

CAUSE

This issue can occur if a Client Applications registry value is missing.

RESOLUTION

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

NOTE: To update your ERD (including security and account information), click Start, click Run, type rdisk /s, press ENTER, and then follow the instructions on the screen to finish creating the disk.

To resolve this problem, add the appropriate class-ID to the Client Applications value in the SBSClients registry key by using Registry Editor (Regedt32.exe):
  1. Use Registry Editor (Regedt32.exe) to view the following key in the registry, and then click it:

    HKEY_LOCAL_MACHINE\Software\Microsoft\BackOffice\SBSClients

  2. On the Edit menu, click Add Value, and then add the following values:

    Value name : Client Applications
    Data type: REG_SZ
    String value: {F7A6A827-AADD-11D1-AE92-0000F875A98A}
  3. Click OK, and then quit Registry Editor.
To perform these changes without using Registry Editor, create a file named Clientapps.reg you can run on your server:
  1. Start Notepad. To do so, click Start, click Run, type notepad clientapps.reg, and then press ENTER.
  2. Copy the following text into the Notepad document:

    REGEDIT4

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BackOffice\SBSClients]
    "Client Applications"="{F7A6A827-AADD-11D1-AE92-0000F875A98A}"
  3. Save the file as "clientapps.reg" (including the quotation marks).
  4. This file can then be sent as an e-mail attachment. To use it, save the attachment as c:\temp\clientapps.reg on the appropriate computer, and then double-click the file to insert the value in the registry.

MORE INFORMATION

Clicking Add Software to a Computer starts the Set Up Computer Wizard. This permits the administrator to select from a list of software that has been pre-installed on the server to be automatically added to client computers following their first reboot and logon after the client computer setup disk has been made. For additional information about related topics, click the article numbers below to view the articles in the Microsoft Knowledge Base:

215721 SBS: How To Troubleshoot Client Application Installation

246352 Existing SBS Client Computers Start Client Program Setup Repeatedly After Upgrading to SBS 4.5


Modification Type:MajorLast Reviewed:11/3/2003
Keywords:kberrmsg kbprb kbsetup KB246357