Setup Cannot Continue After Reformatting Dynamic System/Boot Partition (246119)



The information in this article applies to:

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional

This article was previously published under Q246119

SYMPTOMS

After you reformat the system/boot partition on a dynamic disk during Text-mode Setup and the file-copy portion of Setup finishes, you may experience any of the following symptoms when Setup reboots the computer to start GUI-mode Setup:
  • The computer stops responding (hangs) at a black screen after the computer completes its power-on self test (POST).
  • You receive the following error message:
    Cannot find NTLDR
    Press any key to restart

CAUSE

This behavior occurs because the boot sector's BIOS parameter block (BPB) contains invalid drive translation values that prevent the system from booting.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

260910 How to Obtain the Latest Windows 2000 Service Pack

To continue with Setup, create and then boot from a boot floppy disk as described in the following article in the Microsoft Knowledge Base:

119467 Creating a Boot Disk for an NTFS or FAT Partition

After Setup is finished, use one of the following methods to fix the boot sector's BPB so that Windows 2000 can boot correctly. You can fix the BPB by using the Dskprobe.exe tool that is located on the Windows 2000 CD-ROM in the Support\Tools folder to change the following boot sector fields to match the disk's geometry:
  • Sectors per track
  • Heads (Tracks/Cylinder)

To Fix a FAT32 System/Boot Partition

WARNING: For FAT32 partitions, do not view the boot sector as a FAT boot sector from the View menu and then save it. Doing so corrupts the partition further. Instead, leave the tool in Byte mode when you are editing.
  1. Start Dskprobe.exe.
  2. On the Drives menu, click Physical Drive, and then double-click the physical drive that represents the system/boot drive.
  3. Click to clear the Read Only check box, click Set Active, and then click OK.
  4. On the Sectors menu, click Read using the default settings.
  5. On the Drives menu, click Volume Information, and then note the following values:
    • Sectors / Track
    • Tracks / Cylinder

  6. Using Calculator (Calc.exe), convert the values you noted from decimal to hexadecimal. Note those hexadecimal values for later use. For example:

    Sectors / Track of 63 decimal converts to 3F hexadecimal.
    Tracks / Cylinder of 255 decimal converts to FF hexadecimal.

  7. On the View menu, click Partition Table.
  8. Locate the active partition (the Boot Indicator field lists "SYSTEM") by double-clicking each partition table index entry. Note the Relative Sector number for the active (SYSTEM) partition.
  9. Click the Go button next to the Relative Sector number for the active partition.
  10. On the View menu, click Bytes. This displays the BPB information in hexadecimal.
  11. Change the value at offset 0x018 from 01 hexadecimal to equal the Sectors / Track value in hexadecimal that you noted in step 6.
  12. Change the value at offset 0x01A from 01 hexadecimal to equal the Tracks / Cylinder value in hexadecimal that you noted in step 6.
  13. After you verify that both BPB entries equal the correct hexadecimal values, click Write on the Sectors menu.
  14. Verify that you are writing to the same sector that you recorded for the Relative Sectors setting, and then click Write It.
  15. Quit the Dskprobe.exe tool and restart the computer without the boot floppy disk.

To Fix a FAT (Non-FAT32) or NTFS System/Boot Partition

  1. Start Dskprobe.exe.
  2. On the Drives menu, click Physical Drive, and then double-click the physical drive that represents the system/boot drive.
  3. Click to clear the Read Only check box, click Set Active, and then click OK.
  4. On the Sectors menu, click Read using the default settings.
  5. On the Drives menu, click Volume Information, and then note the following values:
    • Sectors / Track
    • Tracks / Cylinder

  6. On the View menu, click Partition Table.
  7. Locate the active partition (the Boot Indicator field lists "SYSTEM") by double-clicking each partition table index entry. Note the Relative Sector number for the active (SYSTEM) partition.
  8. Click the Go button next to the Relative Sector number for the active partition.
  9. Based on the file system type (FAT or NTFS), click FAT Boot Sector or NTFS Boot Sector on the View menu. This displays the BPB information for editing.
  10. Change the Sectors Per Track entry from 1 to equal the Sectors / Track value that you noted in step 5.
  11. Change the Heads entry from 1 to equal the Tracks / Cylinder value that you noted in step.
  12. After you verify that both BPB entries equal the correct values, click Write on the Sectors menu.
  13. Verify that you are writing to the same sector that you recorded for the Relative Sectors setting, and then click Write It.
  14. Quit the Dskprobe.exe tool and restart the computer without the boot floppy disk.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 1.

MORE INFORMATION

For additional information about the Dskprobe.exe tool, partition tables, boot sectors, and the boot process, please see the Microsoft Windows 2000 Resource Kit.

Modification Type:MajorLast Reviewed:11/13/2003
Keywords:kbbug kbenv kberrmsg kbfix kbsetup kbWin2000SP1Fix KB246119