5250 and 3270 Applets Do Not Find SNA Server (246004)



The information in this article applies to:

  • Microsoft SNA Server 2.11 SP1, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 2.11 SP2, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 3.0 SP1, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 3.0 SP2, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 3.0 SP3, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 3.0 SP4, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 4.0, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 4.0 SP1, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 4.0 SP2, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98
  • Microsoft SNA Server 4.0 SP3, when used with:
    • the operating system: Microsoft Windows 95
    • the operating system: Microsoft Windows 98

This article was previously published under Q246004

SYMPTOMS

On Windows 95/98 computers, the 5250 and 3270 applets may not find the SNA Server when the SNA client configuration is set to Local mode (locate servers by SNA Sub-domain). A TCP/IP error 121 may also occur.

CAUSE

Local client mode (TCP_IP transport) is unreliable on a busy network because the client does not wait long enough for SNA Servers to respond to its sponsor request broadcast.

RESOLUTION

To resolve this problem, obtain the latest service pack for SNA Server 4.0. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack

WORKAROUND

Set the SNA client configuration to Remote mode (locate SNA Servers by name) and enter the sponsor server name (or IP address).

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

This problem was first corrected in SNA Server 4.0 Service Pack 4.

Modification Type:MajorLast Reviewed:6/29/2004
Keywords:kbbug kbfix kbQFE kbSNA400PreSP4fix kbSNA400sp4fix KB246004