MOD2000: If You Change Workflow Procedure Name, You Must Change Name in Script Also (245726)



The information in this article applies to:

  • Microsoft Office 2000 Developer

This article was previously published under Q245726

SYMPTOMS

If you change a validation script procedure name on the solution's workflow Design tab, you must also change all references to that validation script procedure name in the solution's Shared Script tab. Otherwise, if you try the solution functionality linked to the validation script procedure whose name was changed only on the Design tab, you may receive the following error message when you try to save changes:
VBScript:

Your changes were not saved. The form may contain missing or invalid information.

Unknown name.

CAUSE

Changing the validation script procedure name does not automatically update the references to this validation script procedure on the Shared Script tab.

RESOLUTION

If you change the validation script procedure name on the Design tab, change all references to the "old" validation script procedure name on the Shared Script tab.

MORE INFORMATION

Steps to Reproduce the Behavior

  1. From the Access Workflow Designer server computer, deploy the sample Issue Tracking solution.
  2. On the computer with the Access Workflow Designer developer components installed, open Access Workflow Designer.
  3. Open the Workflow Processes node.
  4. Click the IssuesWorkflow process.
  5. On the Design tab, click the Resolved workflow action.
  6. In the Validation script procedure combo box, change the validation script procedure name from State2_Validate_OnTransition1 to State2_Validate_Reactivate.
  7. On the File menu, click Save Changes to save the workflow changes.
  8. On the end-user client computer, set the server as a trusted site.For additional information on how to set up a trusted site on each client computer, click the article number below to view the article in the Microsoft Knowledge Base:

    244318 MOD2000: How to Stop Error Message "This page accesses data on another domain..."

  9. Browse to the Gridview.htm file on the server web site.
  10. Resolve an issue. You may need to create one first.
  11. Save the change.
  12. On the Issue Tracking - All Issues page, click the issue that you just resolved.
  13. Click Activate to reactivate this issue.
  14. Click Save. Note that you receive the error message mentioned in the "Symptoms" section.

Modification Type:MajorLast Reviewed:7/31/2001
Keywords:kbprb kbWorkFlowDesigner KB245726