Inserting an Excel Worksheet Object May Not Work Under Windows NT Terminal Server (245462)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition

This article was previously published under Q245462

SYMPTOMS

The insert object function of a container program may not work if the server program takes a long time to load. For example, if the automatic save feature in Microsoft Excel is turned on and you attempt to insert an Excel spreadsheet into a Microsoft PowerPoint document, any of the following error messages may occur:
Sorry, the source application is busy and cannot respond immediately. You can switch to the other application and try to resolve the problem.

-or-

The Server application, source file, or item cannot be found. You should reinstall the server application.

-or-

The Server Application, source file, or item cannot be found. Make sure the Application is properly installed and that it has not been deleted, moved, or renamed.

CAUSE

Excel takes more time to load when the automatic save add-in is enabled. The load delay in Excel results in RPC_E_SERVERCALL_RETRYLATER being returned. Windows NT is not properly handling the retry mechanism for OLE and therefore RPC_E_CALL_REJECTED is returned. This causes the operation to not succeed.

RESOLUTION

To resolve this problem, obtain the latest service pack for Windows NT Server version 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows NT Server version 4.0, Terminal Server Edition Service Pack 6.

Modification Type:MinorLast Reviewed:9/26/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix kbQFE KB245462