Games: Error message: Setup failed to extract files from <drive:\filename>.CAB (245063)



The information in this article applies to:

  • Flight Simulator X Deluxe
  • Flight Simulator X Standard
  • Links 2003 Championship Edtn EN
  • Microsoft Age of Empires II: The Age of Kings 2.0
  • Microsoft Age of Empires II Expansion: The Conquerors
  • Microsoft Age of Empires II Gold Edition
  • Microsoft Age of Mythology: Gold Edition
  • Microsoft Age of Mythology: The Titans
  • Microsoft Combat Flight Simulator 2: WWII Pacific Theater
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Flight Simulator 2000
  • Microsoft Flight Simulator 2000 Professional Edition
  • Microsoft Flight Simulator 2002
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft Flight Simulator 2004 - Century of Flight
  • Microsoft Halo: Combat Evolved
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Gold Edition
  • Microsoft Rise of Nations: Thrones and Patriots
  • Microsoft Train Simulator
  • Microsoft Zoo Tycoon
  • Microsoft Zoo Tycoon: Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs Expansion Pack
  • Microsoft Zoo Tycoon: Marine Mania Expansion Pack

This article was previously published under Q245063

SYMPTOMS

When you try to install one of the programs that is listed in the "Applies to" section, you may receive an error message that resembles the following, where filename is the name of a required file:
Setup failed to extract files from drive:\filename.CAB. This is most likely caused by low memory (low disk space for swapping file) or corrupted cabinet file. Please restart your machine and run setup again.
back to the top

CAUSE

This issue may occur if one or more of the following conditions are true:
  • There is a problem reading the game disc.
  • There are programs (such as an antivirus program or debugging software) that run in the background and that interfere with the game setup process.
  • The Windows Temp folder is full.
  • Your Windows paging file is damaged.
  • The hard disk where your Microsoft Windows paging file is stored is fragmented.
back to the top

RESOLUTION

To resolve this issue, use one or more of the following methods in the order that they appear.

Method 1: Examine the CD

Examine the CD for visible deformation or scratches. If the disc is damaged, contact Microsoft Sales at (800) 360-7561 to obtain a replacement CD.

back to the top

Method 2: Install and then start the game from a different CD drive or DVD drive

The CD drive may not be able to read the game CD. Try to install the game from a different CD or DVD drive on the same computer or a different computer. If the installation is successful and you can start the game in this test, the problem may be that the original CD- or DVD drive cannot read the game CD. If this issue continues to occur, go to the next method.

back to the top

Method 3: Clean the CD drive

Clean the CD drive by using a CD drive cleaning disc if you have one. If you do not have one, obtain one. CD drive cleaning discs are available in most computer stores. If the issue continues to occur, go to the next method.

back to the top

Method 4: Install the game on a different computer

Note If you do not have another computer to try to install the game on, go to the next method.

Try to install the game on a different computer. If you cannot install the game on a different computer, return the game disc to your software vendor for a replacement package.

If you bought the program in the last 30 days, you may be able to return it to the store where you bought it to obtain a replacement under the Microsoft 30-Day Money Back Guarantee. Check the packaging for information about the 30-Day Money Back Guarantee. To obtain a replacement disc, call the Microsoft Order Desk at (800) 360-7561 and request a replacement for your damaged disc. If you are outside the United States, contact the Microsoft subsidiary for your area. To locate your subsidiary, visit the following Microsoft World Wide Offices Web page:
If you can install the game on a different computer, then the disc is not defective. Go to the next method.

back to the top

Method 5: Perform a clean boot procedure and empty the Temp folder

When you start Microsoft Windows, typically there are a number of programs that start automatically and run in the background that may interfere with the game. These programs may include antivirus and system utility programs. When you perform a clean boot, you prevent these programs from starting automatically.

You must be logged on as an administrator or a member of the Administrators group to complete this procedure. If your computer is connected to a network, network policy settings may also prevent you from completing this procedure.

To restart your computer by using a clean boot procedure, follow these steps if you are using Microsoft Windows XP:

Note You may experience a temporary loss of some services functionality when you follow these steps. Restoring the settings restores the functionality, but the original error message or behavior may return as a result.
  1. Click Start, click Run, type msconfig in the Open box, and then click OK.
  2. On the General tab, click Selective Startup. Under Selective Startup, click to clear the following check boxes:
    • Process SYSTEM.INI File
    • Process WIN.INI File
    • Load Startup Items
  3. On the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
  4. Click OK, and then click Restart.
Click the Play button to view this streaming media demonstration.

For more information or to view steps for other operating systems, click the following article number to view the article in the Microsoft Knowledge Base:

331796 Games: How to perform a clean boot to prevent background programs from interfering with play

After you perform a clean boot procedure, empty the Temp folder in Windows. To do this, use the following method for your version of Windows.

Microsoft Windows XP or Microsoft Windows 2000

Note The Temp folder is located in each specific user folder (for example, C:\Documents and Settings\user name\Local Settings\Temp). To empty the Windows Temp folder, follow these steps:
  1. Click Start, click Run, type %temp%. in the Open box, and then click OK.
  2. On the Edit menu, click Select All.
  3. On the File menu, click Delete.

    When you are prompted to confirm the deletion, click Yes.
  4. Test your game.

Microsoft Windows 98 or Microsoft Windows Millennium Edition

To empty the Windows Temp folder, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type temp, and then click OK.
  3. On the Edit menu, click Select All.
  4. On the File menu, click Delete.

    When you are prompted to confirm the deletion, click Yes.
  5. Test your game.
If the issue continues to occur, go to the next method.

back to the top

Method 6: Turn off Direct Memory Access (DMA) on the CD drive

To turn off DMA on the computer, use the method appropriate for your version of Windows.

Microsoft Windows XP

Note If your drive is not listed, you probably have a small computer system interface (SCSI) drive. DMA options are not available for SCSI drives.
  1. Click Start, and then click Control Panel.
  2. Click Performance and Maintenance, and then click System.
  3. Click the Hardware tab, and then click Device Manager.
  4. Expand the IDE ATA/ATAPI controllers folder, double-click Primary IDE Channel, and then click the Advanced Settings tab.
  5. In the Transfer Mode box, click PIO only, and then click OK.
  6. Double-click Primary IDE Channel, and then click the Advanced Settings tab.
  7. In the Transfer Mode box, click DMA if available, and then click OK.
  8. Restart the computer.
For more information about how to switch the computer's drive controller to DMA mode on Microsoft Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:

310751 Device settings are hard to find in Windows XP

Windows 98 and Microsoft Windows Millennium Edition

To turn off DMA on the CD drive, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. On the Device Manager tab, click View Devices By Type.
  4. Expand CDROM.
  5. Click the CD drive that you want to change, and then click Properties.
  6. Click the Settings tab.
  7. Click to clear the DMA check box, and then click Close.
  8. Close Control Panel, and then restart the computer.
If the issue continues to occur, go to the next method.

back to the top

Method 7: Reduce caching on the CD drive

Note This procedure is for Microsoft Windows 98 and Microsoft Windows Millennium Edition (Me)only.

To reduce caching on the CD drive, follow these steps:
  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click System.
  3. On the Performance tab, click File System.
  4. On the CD-ROM tab, move the Supplemental Cache Size slider to the Small position.
  5. In the Optimize Access Pattern For box, click No Read-Ahead.
  6. Click OK, and then click Close.
  7. When you are prompted to restart your computer, click Yes.
If the issue continues to occur, go to the next method.

back to the top

Method 8: Check the hard disk drive for errors

To check the hard disk drive, use the following method that is appropriate for your system.

Microsoft Windows XP or Microsoft Windows 2000

  1. Open My Computer.
  2. Right-click the hard disk that you want to check, and then click Properties.
  3. On the Tools tab, in the Error-checking section, click Check Now.
  4. Select the Automatically fix file system errors check box and the Scan for and attempt recovery of bad sectors check box, and then click Start.
  5. Allow the process to complete.

Windows 98 or Windows Millennium Edition

  1. Click Start, point to Programs, point to Accessories, point to System Tools, and then click ScanDisk.
  2. Select the drive where the game is installed, and then click Start.
  3. Allow the process to complete.
If this issue continues to occur, go to the next method.

back to the top

Method 9: Defragment the hard disk drive

When a program is installed on the computer, the program's files may be stored in multiple, noncontiguous locations on your hard disk. This is fragmentation. If your hard disk is fragmented, programs on your computer may run slowly.

The Disk Defragmenter tool optimizes the performance of your computer by reorganizing the files on your hard disk in contiguous blocks. When the Disk Defragmenter tool completes the defragmentation of files on your hard disk, your programs may run faster.

Note You can use your computer while Disk Defragmenter is running. However, your computer operates slowly during the defragmentation process and restarts if the contents of the drive change during the process. To defragment your hard disk, follow these steps:
  1. Click Start, point to Programs (or All Programs), point to Accessories, point to System Tools, and then click Disk Defragmenter.
  2. Select the drive where the game is installed, and then click Defragment.
  3. Allow the defragmentation process to complete.

    Note On Windows 98 and Windows Millennium Edition (Me), click OK.
back to the top

Method 10: Rebuild the Windows paging file

To rebuild the Windows paging file, use the method appropriate for your system.

Windows XP

Note To perform this task, you must be recognized as an administrator or a member of the Administrators group on your computer and on the computer that you are managing.
  1. Click Start, and then click Control Panel.
  2. Click Performance and Maintenance.
  3. Click Administrative Tools.
  4. Double-click Computer Management.
  5. In the console tree, right-click Computer Management (Local), and then click Properties.
  6. On the Advanced tab, click Settings under Performance.
  7. In the Virtual memory section, click Change.
  8. In the Drive list, click the drive that contains the paging file that you want to change.
  9. Under Paging file size for selected drive, type 0 for both Initial size (MB) and Maximum size (MB), and then click Set.
  10. Restart the computer, and then repeat steps 1 through 8. Select the System managed size option, and then click Set.
Windows 98 and Windows Millennium Edition
  1. Click Start, and then click Shut Down.
  2. Click Restart in MS-DOS mode, and then click OK.
  3. At the command prompt, type the following lines, and press ENTER after you type each line:

    cd\windows
    del win386.swp
    exit

  4. Click Start, point to Settings, and then click Control Panel.
  5. Double-click System.
  6. On the Performance tab, click Virtual Memory.
  7. Click Let me specify my own virtual memory settings.
  8. In the Hard Disk box, make sure that at least 50 megabytes (MB) of space is available on the hard disk. If multiple hard disks are installed in your computer, make sure that at least 50 MB of space is available on the hard disk where Windows is installed.

    Note If at least 50 MB of space is not available on the hard disk, you must free space by removing old files or programs that you do not need.
  9. Click Cancel, and then click OK.
back to the top

MORE INFORMATION

For more information about how to troubleshoot CD read errors, click the following article numbers to view the articles in the Microsoft Knowledge Base:

218617 How to troubleshoot CD-ROM read issues

321641 How to troubleshoot issues with reading CD, CD-R, CD-RW, and DVD discs

314096 How to troubleshoot CD-ROM drive problems in Windows XP


Modification Type:MajorLast Reviewed:10/2/2006
Keywords:kbhowto kbArtTypeSHOWME kberrmsg kbprb kbsetup KB245063