Too Many Printers Can Cause Unsuccessful Boot (244135)
The information in this article applies to:
- Microsoft Windows NT Server 4.0 Terminal Server Edition
This article was previously published under Q244135 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
SYMPTOMS
When you start your computer, you may receive the following error message:
Windows NT could not start because the following file is missing or corrupt:
\%SystemRoot%\System32\Config\SystemHardware Profile/Last Known Good menu
CAUSE
This behavior can occur if there are too many printers installed. Based on the number and types of drivers involved, the problem may start at around 900 printers. This issue can occur for local printers as well as for network printers, or for a combination of both that exceeds around 900 printers.
Before you install the fix mentioned in the "Resolution" section, the information for local printers is saved to the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Printers
The information for network printers is saved to the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print\Providers\LanManPrintServices
Because of this, the System subkey of the HKEY_LOCAL_MACHINE hive in the registry may become too large to fit into the allocated memory space and may preventing the system from booting.
RESOLUTIONWindows NT Server 4.0, Terminal Server EditionTo resolve this problem, obtain the latest service pack for Windows NT Server version 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
152734 How to Obtain the Latest Windows NT 4.0 Service Pack
NOTE: To activate this fix, you must add the following registry value:
Key: HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Print
Value Name : UseSoftwareKey
Value Type : REG_DWORD
Data : 1
Windows NT 4.0 Server and Workstation
There is a separate hotfix that addresses this issue for Windows NT 4.0.
For additional information, click the article number below
to view the article in the Microsoft Knowledge Base:
239907 Too Many Printers Can Cause Unsuccessful Boot
WORKAROUND
For possible workarounds, see the following article in the Microsoft Knowledge Base:
102721 Err Msg: Windows NT Could Not Start Because the Following...
STATUSWindows NT Server 4.0, Terminal Server EditionMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows NT Server version 4.0, Terminal Server Edition Service Pack 6.Windows NT 4.0Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.
Modification Type: | Minor | Last Reviewed: | 9/26/2005 |
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Keywords: | kbHotfixServer kbQFE kbbug kbfix kbQFE KB244135 |
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