MOD2000: User List Not Synchronized for Suspect Database (244043)
The information in this article applies to:
- Microsoft Office 2000 Developer
This article was previously published under Q244043 Moderate: Requires basic macro, coding, and interoperability skills.
This article applies only to a Microsoft Access project (.adp).
SYMPTOMS
If your Access Workflow Designer server computer hosts two or more solutions and one or more of the solution databases is either renamed or deleted, the database becomes suspect in Microsoft SQL Server. Because the database is suspect, when you try to synchronize the user list for any of the hosted solution databases, the following error message appears:
User Directory synchronization failed with the following errors:
Exceptions occurred while invoking method SynchronizeUserList
Error(80004005) in Microsoft OLE DB Provider for SQL Server:
Cannot open database requested in login 'database name'. Login fails.
Exception occurred.
CAUSE
When the Access Workflow Designer attempts to synchronize the user list for a solution database, it cycles through and opens all databases stored on the server. If one or more databases are damaged, when the Access Workflow Designer opens the damaged database, no databases can be synchronized.
RESOLUTION
Either restore and re-attach a copy of the suspect database (if it was deleted), or rename the .mdf and .ldf files back to their original file names. After the database appears as it did before all Microsoft SQL Server services were stopped, you can synchronize the user list for all solution databases.
Modification Type: | Major | Last Reviewed: | 7/31/2001 |
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Keywords: | kbprb kbWorkFlowDesigner KB244043 |
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