MOD2000: User List Not Synchronized for Suspect Database (244043)



The information in this article applies to:

  • Microsoft Office 2000 Developer

This article was previously published under Q244043
Moderate: Requires basic macro, coding, and interoperability skills.

This article applies only to a Microsoft Access project (.adp).

SYMPTOMS

If your Access Workflow Designer server computer hosts two or more solutions and one or more of the solution databases is either renamed or deleted, the database becomes suspect in Microsoft SQL Server. Because the database is suspect, when you try to synchronize the user list for any of the hosted solution databases, the following error message appears:
User Directory synchronization failed with the following errors:

Exceptions occurred while invoking method SynchronizeUserList Error(80004005) in Microsoft OLE DB Provider for SQL Server: Cannot open database requested in login 'database name'. Login fails. Exception occurred.

CAUSE

When the Access Workflow Designer attempts to synchronize the user list for a solution database, it cycles through and opens all databases stored on the server. If one or more databases are damaged, when the Access Workflow Designer opens the damaged database, no databases can be synchronized.

RESOLUTION

Either restore and re-attach a copy of the suspect database (if it was deleted), or rename the .mdf and .ldf files back to their original file names. After the database appears as it did before all Microsoft SQL Server services were stopped, you can synchronize the user list for all solution databases.

MORE INFORMATION

Steps to Reproduce Behavior

  1. On the computer where the Access Workflow Designer server components are installed, deploy the Issue Tracking application at least twice. Name the first instance IT1 and the second instance IT2.
  2. Stop all Microsoft SQL Server services using Service Manager.
  3. Rename the .mdf and .ldf for the IT1 instance of the Issue Tracking solution.
  4. Restart all Microsoft SQL Server services using Service Manager.
  5. Start Microsoft SQL Server Enterprise Manager. Notice that the IT1 database is marked as suspect.
  6. Start the Team Solutions Manager.
  7. Click the User Information tab.
  8. Click the Synchronize Now button.
You next see the error message described in the "Symptoms" section of this article.

Modification Type:MajorLast Reviewed:7/31/2001
Keywords:kbprb kbWorkFlowDesigner KB244043