MOD2000: Workflow Actions Are Not Listed in Workflow Order (243916)
The information in this article applies to:
- Microsoft Office 2000 Developer
This article was previously published under Q243916 SYMPTOMS
In Access Workflow Designer, workflow actions in the Microsoft Office Developer Workflow Toolbar Control appear in the order in which they were created, not in the order shown in the workflow diagram.
CAUSE
In Access Workflow Designer, any workflow state can potentially be reached by any number of paths through the workflow. Because there can be more than one path from one workflow state to another, there really is no way to determine the order in which events occur.
RESOLUTION
You can change the order in which the workflow actions are displayed by manually setting the Position column value in the corresponding workflow actions table. For example, if the table to which you added workflow is named Test, modify the Position column value in the testWorkflowActions table. NOTE: Before you can change the Position column value in the corresponding workflow actions table, you must create a primary key on the Id column. To create a primary key on the Id column in the workflow actions table, follow these steps:
- Open the Microsoft Access project (.adp) exclusively.
- Open the workflow actions table in Design view.
- Click the Id column.
- On the Edit menu, click Primary Key.
- Save the table, and then close it. You can now modify the Position column value.
Modification Type: | Major | Last Reviewed: | 7/31/2001 |
---|
Keywords: | kbprb kbWorkFlowDesigner KB243916 |
---|
|