MapPoint Err Msg: Failed to Open Default Map Templates and Demographic Data (243707)



The information in this article applies to:

  • Microsoft MapPoint 2000
  • Microsoft MapPoint 2001
  • Microsoft MapPoint 2002
  • Microsoft Streets and Trips 2003
  • Microsoft Streets & Trips 2004

This article was previously published under Q243707

SYMPTOMS

When you start Microsoft MapPoint or Microsoft Streets and Trips, you may receive one of the following error messages:
Failed to open default map templates and demographic data.
Demographic data is missing or corrupted. Please reinstall product name.

CAUSE

This issue may occur if any of the following conditions is true:
  • The New North American Map.stt file is damaged or you have an incorrect version of the file.
  • The Newmap.ptt file is damaged or an incorrect version.
  • The Mdac_typ.exe installation did not finish successfully.

RESOLUTION

To resolve this issue, use the following methods in the order in which they are presented.

Note If you are running Windows 95, go to "Windows 95," later in this section.

Remove MapPoint or Streets and Trips

  1. Click Start, and then click Control Panel.
  2. Double-click Add or Remove Programs.
  3. Click to select the program that you want to remove, and then click Change/Remove.
  4. Follow the instructions on the screen to remove the program.
  5. Delete the drive:\Program Files\MapPoint (or Streets and Trips) folder, where drive is the drive letter of the hard disk where the program is installed.

Download MDAC

To download the latest version of Microsoft Data Access Components (MDAC):
  1. Visit the following Microsoft Web site:
  2. Locate the newest version of MDAC that is appropriate for your operating system and language, and then click the link to read the release details.
  3. Verify that the version of MDAC is appropriate for your system, click the Download MDAC version link, and follow the download instructions.
  4. When you are prompted to "click to Save This Program to Disk," click OK.
  5. In the Save in box, click Desktop, and then click Save.

Clean Boot Your Computer

To clean boot your computer:
  1. Click Start, and then click Run.
  2. In the Open box, type msconfig, and then click OK.
  3. Click the General tab, and then click Selective Startup.
  4. Click to clear the following check boxes under Selective Startup:

    Process SYSTEM.INI file
    Process WIN.INI file
    Load Startup Items

  5. Click the Services tab, click to select the Hide All Microsoft Services check box, and then click Disable All.
  6. Click OK, and then click Restart to restart the computer.

    Note To restore the computer to use normal startup, click Normal Startup - load all device drivers and services on the General tab in the System Configuration utility, click OK, and then click Restart to restart the computer.
For additional information, click the following article numbers to view the articles in the Microsoft Knowledge Base:

310353 How to perform a clean boot in Windows XP

267288 How to perform a clean boot in Windows Millennium Edition

Install MDAC

To install the latest version of MDAC:
  1. Double-click the Mdac_typ.exe file on the Windows desktop.
  2. Follow the instructions on the screen to install the MDAC update.
  3. When you are prompted to restart the computer, click Restart Windows, and then clean boot your computer.
Note You may receive the following error message after you restart the computer:
Unable to open response file C:\Temp\Odbcconf.tmp
For additional information about this error message, click the following article number to view the article in the Microsoft Knowledge Base:

218184 PRB: Restart After MDAC Installation Causes Error

Reinstall MapPoint or Streets and Trips

To reinstall MapPoint or Streets and Trips:
  1. Insert the MapPoint or Streets and Trips CD-ROM into your CD-ROM drive.

    If MapPoint or Streets and Trips Setup does not start automatically:
    1. Click Start, and then click Run.
    2. In the Open box, type the following line, and then click OK:

      cd-rom:\setup.exe

      where cd-rom is the drive letter of your CD-ROM drive.
  2. Follow the instructions on the screen to install MapPoint or Streets and Trips.
  3. When the installation process is complete, click OK, and then restart Windows normally.

Windows 95

Note Streets and Trips 2003 will not run on Windows 95.

Download DCOM95 for Windows 95

To download DCOM95 for Windows 95:
  1. Connect to the following Microsoft Web site:
  2. Click the link next to the download site closest to you.
  3. Click Save this program to disk, and then click OK.
  4. In the Save in box, click Desktop, and then click Save.

Download MDAC

To download the latest version of MDAC:
  1. Connect to the following Microsoft Web site:
  2. Under Select an Install Option, click the latest version of MDAC RTM for your language version of Microsoft Windows, and then click Go to Download.
  3. Click Save this program to disk, and then click OK.
  4. In the Save in box, click Desktop, and then click Save.

Clean Boot Your Computer

To clean boot your computer:
  1. Restart the computer. When you see the "Starting Windows 95" message, press the F8 key, and then select Step By Step Confirmation from the Startup menu.
  2. Press Y at each prompt except for the following two prompts, at which you must press N:
    • Process your startup device driver (CONFIG.SYS) [Enter=Y, Esc=N]?
    • Process your startup command file (AUTOEXEC.BAT) [Enter=Y,Esc=N]?
  3. Quit all programs that are running except Explorer and Systray. To do this:
    1. Press CTRL+ALT+DELETE.
    2. Click the program you want to quit, and then click End Task.
    3. If you receive a message that the program is busy or not responding, click End Task again.
    Repeat this step until you have quit all programs except Explorer and Systray.
  4. Disable any anti-virus or disk tool programs installed on the computer. For information about how to disable these programs, see the printed or online documentation for the program.
Note To restore your original Startup options, restart the computer normally, and then enable any anti-virus or disk tool programs installed on the computer. For information about how to enable these programs, see the printed or online documentation for the program.

For additional information about how to clean boot Windows 95, click the following article number to view the article in the Microsoft Knowledge Base:

177604 Multimedia: Troubleshooting Using Clean Boot of Windows 95

Install DCOM95 for Windows 95

  1. Double-click the Dcom95.exe file on the Windows desktop.
  2. Follow the instructions on the screen to install DCOM95 for Windows 95.
  3. When you are prompted to restart the computer, click Restart Windows, and then clean boot your computer as described in the "Clean Boot Your Computer" section of this article.

Install MDAC

To install MDAC:
  1. Double-click the Mdac_typ.exe file on the Windows desktop.
  2. Follow the instructions on the screen to install the MDAC update.
  3. When you are prompted to restart the computer, click Restart Windows, and then clean boot your computer.
Note: You may receive the following error message after you restart the computer:
Unable to open response file C:\Temp\Odbcconf.tmp
For additional information about this error message, click the following article number to view the article in the Microsoft Knowledge Base:

218184 PRB: Restart After MDAC Installation Causes Error

Reinstall MapPoint

To reinstall MapPoint:
  1. Insert the MapPoint CD-ROM into your CD-ROM drive.

    If MapPoint Setup does not start automatically, click Start, click Run, type cd-rom:\setup.exe in the Open box, and then click OK.

    In this example, cd-rom is the drive letter of your CD-ROM drive.
  2. Follow the instructions on the screen to install MapPoint.
  3. When the installation process is complete, click OK, and then restart Windows normally.

Modification Type:MinorLast Reviewed:10/21/2004
Keywords:kbenv kberrmsg kbprb kbsetup KB243707