XFOR: Exchange Migration Wizard Stops Responding After You Use Outlook 2000 (243659)



The information in this article applies to:

  • Microsoft Outlook 2000

This article was previously published under Q243659
IMPORTANT: This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:

256986 Description of the Microsoft Windows Registry

SYMPTOMS

When you use User Manager for Domains functions of Microsoft Exchange Server, such as Migration Wizard and the creation of new mailboxes, may stop responding after you install and run Outlook 2000.

When you attempt to create mailboxes by using User Manager for Domains, you may receive the following error message:
An unexpected, unknown error has occurred.

MAPI or an unspecified service provider. ID no. 8004010f-0000-00000000

CAUSE

This behavior can occur, and this error message is generated, because Outlook 2000 has overwritten the Mapi32.dll. Although User Manager functionality, such as creating Windows NT accounts and assigning groups, functions as expected, the Exchange Extension reports a MAPI error when you attempt to create a mailbox as part of the new account process.

NOTE: The Exchange Administrator program is able to create mailboxes and associated Windows NT accounts as expected.

Outlook 2000 recognizes the previous version of the Mapi32.dll file and wants to change it. When you start Outlook 2000, Outlook verifies that the Mapi32.dll file in the system directory is the stub .dll that Outlook 2000 originally installed. If Outlook detects that the current Mapi32.dll is not the stub version, Outlook displays an error message or displays no user interface (UI) and behaves according to a registry key that can be set.

WORKAROUND

WARNING: If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

To work around this behavior, reinstall Admin.exe, which installs the version of Mapi32.dll necessary to resume Exchange Server functions, and then add the FixMapi registry key so that Outlook does not run FixMapi. To do so:
  1. Browse to the following registry key:

    HKEY_CURRENT_USER\Software\Microsoft\Office\9.0\Outlook

  1. On the Edit menu, click New, and then click DWORD Value.
  2. Name the new DWORD Value, FixMAPI.
  3. On the Edit menu, click Modify.
  4. Click Decimal, in the Base section, type 0 in the Value Data box, and then click OK.
  5. On the Registry menu, click Exit.
You are able to run Outlook 2000, the Migration Wizard, and User Manager to create mailboxes without conflict.

MORE INFORMATION

When the Microsoft Exchange Migration Wizard stops responding and does not function because of an incorrect Mapi32.dll, the following event ID messages are logged in the Application event log:

Event ID : 10,000
Source: MSExchangeMig
Type: Error
Description:
Could not create a profile for Account: Username at XXX. Please reboot your system to clear hung profiles.

-and-

Event ID: 7026
Source: MSExchangeMig
Type: Error
Description:
Migration Aborted due to Mapi logon failure.

-and-

Event ID: 8002
Source: MSExchangeMig
Type: Error
Description:
Errors occurred during the Migration Process. A recovery file has been created called D:\TEMP\00000000.PRI.


Modification Type:MinorLast Reviewed:4/25/2005
Keywords:KB243659