Shared Folders Connections Fail Using Same User ID with Different Passwords (243388)
The information in this article applies to:
- Microsoft SNA Server 4.0
- Microsoft SNA Server 4.0 SP1
- Microsoft SNA Server 4.0 SP2
- Microsoft SNA Server 4.0 SP3
This article was previously published under Q243388 SYMPTOMS
Shared Folders connections fail when two or more AS/400 definitions use the same User ID, but different passwords. When attempting to connect to a folder definition on one of the AS/400s, customers may receive the following error message:
X:\ is not accessible.
While accessing the hard disk, a disk operation failed even after retries.
CAUSE
The Shared Folders gateway service stores only one instance of the User ID and password. Because of this, one password is used for all AS/400 definitions with the same User ID. This results in security violations, which can be seen in a Shared Folders Gateway API trace.
RESOLUTIONTo resolve this problem, obtain the latest service pack for SNA Server 4.0. For additional information, click the following article number to view the article in the
Microsoft Knowledge Base:
215838 How to Obtain the Latest SNA Server Version 4.0 Service Pack
WORKAROUND
This problem only affects two or more AS/400 definitions using the same User ID, but different passwords. Customers can avoid this problem by using a unique User ID for each AS/400 definition, or by using the same User ID and same password for each AS/400 definition.
STATUSMicrosoft has confirmed that this is a problem in Microsoft SNA Server version 4.0.
This problem was first corrected in SNA Server 4.0 Service Pack 4.MORE INFORMATION
The Shared Folders gateway service should be stopped before applying this fix, and then restarted after the fix has been successfully applied.
Modification Type: | Major | Last Reviewed: | 11/26/2003 |
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Keywords: | kbbug kbfix kbQFE kbSNA400PreSP4fix kbSNA400sp4fix KB243388 |
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