Windows 98 Second Edition Problems with NDIS Intermediate Drivers (243199)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition

This article was previously published under Q243199

SYMPTOMS

On a Windows 98 Second Edition-based computer that is using networking software that is implemented as a Network Driver Interface Specification (NDIS) intermediate driver, one of the following symptoms may occur:
  • The computer may stop responding (hang) during startup or shutdown.
  • Your network throughput and overall network performance may gradually decrease, sometimes to the point that the computer hangs or becomes completely unresponsive to network requests.
NOTE: To more effectively search the Microsoft Knowledge Base, use keywords that relate to your issue. If you are searching for troubleshooting information that is not mentioned in this article, search the Microsoft Knowledge Base again by using keywords that are listed in the following Microsoft Knowledge Base article:

242450 How to Query the Microsoft Knowledge Base Using Keywords

CAUSE

This problem can occur if the NDIS intermediate driver code is preempted by the operating system when it is not safe to do so. As a result, a "race" or "deadlock" condition may occur, causing the operating system to hang.

RESOLUTION

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem immediately, download the fix by clicking the download link later in this article or contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The following files are available for download from the Microsoft Download Center:
Release Date: Apr-20-2000

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to Obtain Microsoft Support Files from Online Services

Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file. The English-language version of this fix should have the following file attributes or later:
   Date       Time     Version     Size      File name
   ---------------------------------------------------
   10/20/99   4:48pm   4.10.2224   166,053   Ndis.vxd 
				

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

This problem is known to occur with the following networking software:
  • 3Com DynamicAccess SW 2.0
  • AT&T IPSec Virtual Private Networking
  • Laplink.com Laplink
The third-party products that are discussed in this article are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, regarding the performance or reliability of these products.
For additional information on Windows 98 and Windows 98 SE hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Modification Type:MinorLast Reviewed:9/5/2006
Keywords:kbHotfixServer kbQFE kbdownload kbenv kbgraphxlinkcritical kbnetwork kbprb KB243199