Microsoft Digital Video May Lose IEEE 1394 Device Audio (243174)



The information in this article applies to:

  • Microsoft Windows 98 Second Edition

This article was previously published under Q243174

SYMPTOMS

Microsoft Digital Video Splitter may pass faulty audio samples from some IEEE 1394 (High Performance Serial Bus, or "FireWire") devices instead of duplicating the last good audio sample. As a result, Microsoft DirectShow clients in general, and DVD playback programs in specific, may experience audio dropout or a loss of audio rendering.

CAUSE

Microsoft Digital Video may not reset a IEEE 1394 device's Plug Control Register (PCR) to its default state. Some IEEE 1394 devices may not be able to handle this because they cannot program the PCR.

RESOLUTION

A supported hotfix is now available from Microsoft, but it is only intended to correct the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the hotfix. For a complete list of Microsoft Product Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
   Date         Time   Version    Size     File name  Platform
   ------------------------------------------------------------------
   30-Sep-1999  15:31  4.10.2224   54,944  Msdv.sys   Windows 98 SE
   14-Jul-1999  11:54  6.1.5.319  187,488  Qcap.dll   Windows 98 SE
   11-Feb-2000  15:56  6.2.10.1   216,336  Qdv.dll    Windows 98 SE
				
NOTE: The file times in this table show Pacific time (Greenwich mean time -8:00).


STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:

206071 General Information About Windows 98 and Windows 98 Second Edition Hotfixes


Modification Type:MinorLast Reviewed:10/18/2005
Keywords:kbHotfixServer kbQFE kbHardware kbprb KB243174