Cisco Cable Modem Unable to Receive IP Address from Windows NT 4.0 DHCP Server (242183)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q242183

SYMPTOMS

When you use a Cisco cable modem, you may not be able to receive an Internet Protocol (IP) address from a Windows NT 4.0 Server-based computer using Dynamic Host Configuration Protocol (DHCP). The server generates an "error 10040" error message.

CAUSE

This behavior occurs because the cable modem client sends a packet larger than the maximum length of the DHCP packet as defined in the RFC (576 bytes).

RESOLUTION

Windows NT Server or Workstation 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:

Windows NT Server 4.0, Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


STATUS

Microsoft has confirmed that this is a problem in Windows NT 4.0 and Windows NT Server 4.0, Terminal Server Edition. This problem was first corrected in Windows NT Server version 4.0, Terminal Server Edition Service Pack 6.

Modification Type:MajorLast Reviewed:11/20/2002
Keywords:kbbug KB242183