Trey Research Shows "Product No Longer Exists" When Attempting to View Purchase (241953)
The information in this article applies to:
- Microsoft Site Server 3.0 Commerce Edition
This article was previously published under Q241953 SYMPTOMS
When you purchase a subscription from the Trey Research sample commerce site and click the Click here for a list of categories you have subscribed to link, the subscription you purchased is not listed.
Instead, in the table under the list of current subscriptions, the Name column shows the following:
(Product no longer exists)
CAUSE
When a member is added to a group (subscription), the next time the Active User Object (AUO) is instantiated for the user in the ASP page, the cache is not updated.
RESOLUTION
Perform the following steps to force the broker cache to update every time the object is instantiated:
- Use a text editor to open the Mem_ds.asp file, located in the \Microsoft Site Server\Sites\Commerce\Tr\Include folder.
-
After line 14 (which contains the following code):
Set gMemUserObject = Server.CreateObject("Membership.UserObjects")
add the following new line of code:
gMemUserObject.GetInfo
- Save the file and close the editor.
STATUSMicrosoft has confirmed that this is a problem in Site Server version 3.0, Commerce Edition.
Modification Type: | Major | Last Reviewed: | 6/24/2004 |
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Keywords: | kbbug kbpending KB241953 |
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