BUG: Setting Application Proxy RSN to Spaces Causes Activation to Fail (241687)



The information in this article applies to:

  • Microsoft COM+ 1.0
  • Microsoft COM+ 1.5

This article was previously published under Q241687

SYMPTOMS

When a COM+ application is created on a client machine by running an Exported Application Proxy, the Remote Server Name (RSN) of the COM+ application is blank. Activation through an Application Proxy by a client then fails because the Remote Server Name is blank. You may receive the following error message:
Run time Error '429': ActiveX component can't create object.

CAUSE

Setting the Export option "Application Proxy RSN" to spaces causes this behavior.

RESOLUTION

To work around this problem, reset the Remote Server Name property on LocalComputer to an empty string and re-export the application proxy.

This problem does not occur if the Application Proxy RSN value is set to NULL or Empty string. In this case, Export functionality uses the ComputerName from which Export is called.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed at the beginning of this article.

MORE INFORMATION

Steps to Reproduce the Behavior:

  1. In COM+ Explorer, right-click the computer name from which the application has to be exported and click Properties. Click the Options tab. Set the Application Proxy RSN value to spaces.

    -or-

    Set the Application Proxy RSN value to spaces by using the Admin SDK as follows:
    Dim cat
    Dim apps
    Set cat = CreateObject("COMAdmin.COMAdminCatalog")
    Set apps = cat.GetCollection("LocalComputer")
    apps.Populate
    apps.Item(0).Value("ApplicationProxyRSN") = "  "
    apps.SaveChanges
    						
  2. Create a new COM+ application.
  3. Export this application as the application proxy.
  4. Install this application proxy on another computer.
  5. After installation, check the activation page of the proxy RSN. It will be empty.
This causes the activation to fail because the Remote Server Name is unknown.

Modification Type:MajorLast Reviewed:10/15/2002
Keywords:kbBug kbDSupport kbSysAdmin KB241687