Roaming Profile May Not Be Saved to the Server (241572)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP4
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Workstation 4.0 SP5
  • Microsoft Windows NT Workstation 4.0 SP6a
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6a

This article was previously published under Q241572

SYMPTOMS

If you use the Internet Connection Wizard (ICW) and you select the I want to set up a new connection on this computer option, your roaming profile may not be saved to the server.

CAUSE

ICW calls the Telephony service to get user information. The Telephony service opens a subkey of HKEY_CURRENT_USER by using the RegOpenKeyEx function, and then closes the key when it is finished.

However, RegOpenKeyEx opens not only the subkey, but a predefined root key. In this case, the root key is HKEY_CURRENT_USER. So, the HKEY_CURRENT_USER key is still opened by the Telephony service, and Winlogon.exe cannot unload the registry when you log off. Therefore, your roaming profile is not saved to the server.

RESOLUTION

Windows NT Workstation and Windows NT Server

A supported fix is now available from Microsoft, but it is only intended to correct the problem that is described in this article. Apply it only to computers that are experiencing this specific problem.

To resolve this problem, contact Microsoft Product Support Services to obtain the fix. For a complete list of Microsoft Product Support Services phone numbers and information about support costs, visit the following Microsoft Web site:NOTE: In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

The English-language version of this fix should have the following file attributes or later:
   Date      Time    Size     File name    Platform
   ------------------------------------------------
   09/01/99  04:18p  152,848  Tapisrv.exe  Intel
   09/01/99  04:16p  243,472  Tapisrv.exe  Alpha
				

Windows NT Server 4.0, Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:

152734 How to Obtain the Latest Windows NT 4.0 Service Pack


WORKAROUND

To work around this behavior, stop the Telephony service before you log off.

STATUS

Windows NT Workstation and Windows NT Server

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Windows NT Server 4.0, Terminal Server Edition

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows NT Server 4.0, Terminal Server Edition Service Pack 5.

Modification Type:MinorLast Reviewed:9/23/2005
Keywords:kbHotfixServer kbQFE kbbug kbfix KB241572