The System or Processor Queue Length Counter Gives Higher than Expected Values (241527)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP4
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP5
  • Microsoft Windows NT Server 4.0 Terminal Server Edition SP6
  • Microsoft Windows NT Server 3.51
  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server 4.0 SP1
  • Microsoft Windows NT Server 4.0 SP2
  • Microsoft Windows NT Server 4.0 SP3
  • Microsoft Windows NT Server 4.0 SP4
  • Microsoft Windows NT Server 4.0 SP5
  • Microsoft Windows NT Server 4.0 SP6
  • Microsoft Windows NT Server, Enterprise Edition 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP4
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP5
  • Microsoft Windows NT Server, Enterprise Edition 4.0 SP6
  • Microsoft Windows NT Workstation 3.51
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 SP1
  • Microsoft Windows NT Workstation 4.0 SP2
  • Microsoft Windows NT Workstation 4.0 SP3
  • Microsoft Windows NT Workstation 4.0 SP4
  • Microsoft Windows NT Workstation 4.0 SP5
  • Microsoft Windows NT Workstation 4.0 SP6
  • Microsoft BackOffice Server 4.0
  • Microsoft BackOffice Server 4.5

This article was previously published under Q241527

SYMPTOMS

When you monitor the System or Processor Queue Length counter from a remote location, you can observe higher values than when you monitor this counter locally.

CAUSE

This behavior can occur because the Processor Queue Length counter is an instantaneous counter that collects all the threads in the system, and then counts all the ready threads at that instant.

If the system is blocked for some reason, for example, the system is handling a remote procedure call (RPC) network operation, the ready thread count at that instant can build up to a very high number. This high count number is usually temporary, however; as soon as the blocking thread is completed, the ready threads can be processed.

WORKAROUND

To work around this behavior, you can obtain a value if you perform the Performance Monitor logging locally, and then view the log from a remote computer.


Modification Type:MajorLast Reviewed:5/14/2003
Keywords:kbenv kbprb KB241527