Works 2000: Works Does Not Start When You Double-Click a Works Document (241165)



The information in this article applies to:

  • Microsoft Works 2000
  • Microsoft Works Suite 2000

This article was previously published under Q241165

SYMPTOMS

When you double-click a Microsoft Works database, spreadsheet, or word processor document on the Microsoft Windows desktop or in Microsoft Windows Explorer, Works 2000 may not start, you may be prompted to select the program you want to use to open the file, or you may receive one of the following error messages:

  • Cannot Find the Document path. Check the drive and directory.
  • Cannot Find the Directory path.
In addition, when you right-click a Works database, spreadsheet, or word processor document on the Windows desktop or in Windows Explorer, the New, Open, Print, or PrintTo commands may not appear on the shortcut menu.

CAUSE

This behavior can occur if the file name extension for the document is not associated with Works 2000, or if the name of the document does not include a Works document file name extension.

RESOLUTION

To resolve this issue, use the following methods in the order in which they are presented.

Verify That the File Name Includes the Correct File Extension

To do this:

  1. Click Start, point to Programs, and then click Windows Explorer.
  2. On the View menu, click Options or Folder Options.
  3. Click the View tab.
  4. Under Advanced Settings, click to clear the Hide file extensions for known file types check box, and then click Apply.
  5. Click Close.
  6. Verify that the document you want to use has the correct file extension. If the document does not have the correct file extension:

    1. Right-click the document, and then click Rename.
    2. Press the END key, press the PERIOD (.) key, type the correct three-letter file extension for the document, and then press ENTER.
    The following table lists the Microsoft Works document types, and their associated file extensions.

    NOTE: If you have Microsoft Works Suite 2000, the word processor extention listed in the following table do not apply. Microsoft Word is the word processor program included in Works Suite 2000.
    Registered File TypeExtensions
    Microsoft Works DatabaseWDB BDB
    Microsoft Works Spreadsheet or ChartWKS BKS
    Microsoft Works Word ProcessorWPS WPT
If the issue continues to occur, proceed to the next method.

Remove and Reinstall Works 2000

To remove and reinstall Works 2000:

  1. Click Start, point to Settings, and then click Control Panel.
  2. Double-click Add/Remove Programs.
  3. In the list of installed programs, click Microsoft Works 2000, and then click Add/Remove.
  4. Follow the instructions on the screen to remove Works 2000.
  5. Reinstall Works 2000.
NOTE: When you remove Works 2000, none of the documents you created using Works are removed.

If the issue continues to occur, proceed to the next method.

Check the File Type Associations

On the View menu in Windows Explorer, click Options or Folder Options, click the File Types tab, and then use the following methods to check the registered file types for Works 2000.

Microsoft Works Database

  1. In the Registered file types box, click to select Microsoft Works Database, and then click Edit.

    If the Microsoft Works Database file type is missing:
    1. Click New Type.
    2. In the Description of type box, type Microsoft Works Database.
    3. In the Associated extension box, type WDB BDB.
    4. Click to select the Enable Quick View check box.
  2. In the Actions box, double-click the open action.

    If the open action is missing from the Actions box, click New, and then type open in the Action box.
  3. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    "drive:\Program Files\Microsoft Works\WksDB.exe" "%1"

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  4. Click OK.
  5. In the Actions box, click open, and then click Set Default.
  6. In the Actions box, double-click the print action. If the print action is missing from the Actions box, click New, and then type print in the Action box.
  7. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    drive:\Program Files\Microsoft Works\wksdb.exe /p "%1"

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  8. Click OK.
  9. In the Actions box, double-click the PrintTo action. If the PrintTo action is missing from the Actions box, click New, and then type PrintTo in the Action box.
  10. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    drive:\Program Files\Microsoft Works\wksdb.exe /f "%1" "%2" "%3" "%4"

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  11. Click OK, and then click OK again.

Microsoft Works Spreadsheet or Chart

  1. In the Registered file types box, click to select Microsoft Works Spreadsheet or Chart, and then click Edit.

    If the Microsoft Works Spreadsheet or Chart file type is missing:
    1. Click New Type.
    2. In the Description of type box, type Microsoft Works Spreadsheet or Chart.
    3. In the Associated extension box, type WKS BKS.
    4. Click to select the Enable Quick View check box.
  2. In the Actions box, double-click the open action. If the open action is missing from the Actions box, click New, and then type open in the Action box.
  3. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    "drive:\Program Files\Microsoft Works\WksSS.exe" "%1"

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  4. Click OK.
  5. In the Actions box, click open, and then click Set Default.
  6. In the Actions box, double-click the print action. If the print action is missing from the Actions box, click New, and then type print in the Action box.
  7. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    drive:\Program Files\Microsoft Works\wksss.exe /p "%1"

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  8. Click OK.
  9. In the Actions box, double-click the PrintTo action. If the PrintTo action is missing from the Actions box, click New, and then type PrintTo in the Action box.
  10. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    drive:\Program Files\Microsoft Works\wksss.exe /f "%1" "%2" "%3" "%4"

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  11. Click OK, and then click OK again.

Microsoft Works Word Processor

  1. In the Registered file types box, click to select Microsoft Works Word Processor, and then click Edit.

    If the Microsoft Works Word Processor file type is missing:
    1. Click New Type.
    2. In the Description of type box, type Microsoft Works Word Processor.
    3. In the Associated extension box, type WPS WPT.
    4. Click to select the Enable Quick View check box.
  2. In the Actions box, double-click the New action. If the New action is missing from the Actions box, click New, and then type New in the Action box.
  3. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    drive:\Program Files\Microsoft Works\WksWP.exe /NEW

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  4. Click OK.
  5. In the Actions box, double-click the Open action. If the Open action is missing from the Actions box, click New, and then type Open in the Action box.
  6. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    "drive:\Program Files\Microsoft Works\WksWP.exe" /SHELL "%1"

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  7. Click OK.
  8. In the Actions box, click Open, and then click Set Default.
  9. In the Actions box, double-click the Print action. If the Print action is missing from the Actions box, click New, and then type Print in the Action box.
  10. Verify that the Application used to perform this action box contains the following command line (including the quotation marks)

    drive:\Program Files\Microsoft Works\WksWP.exe /PRINT "%1"

    where drive is the drive letter of the hard disk on which Works 2000 is installed.

    If the Application used to perform this action box is empty or contains the wrong command line, type the correct command line (including the quotation marks) in the Application used to perform this action box.
  11. Click OK, and then click OK again.

MORE INFORMATION

This issue can also occur if you unsuccessfully use File Manager to associate a file extension with Works 2000. For information about how to resolve this issue, please click the article number below to view the article in the Microsoft Knowledge Base:

134846 Problems with File Manager Associations in Windows 95


Modification Type:MajorLast Reviewed:10/28/2003
Keywords:kbenv kberrmsg kbprb kbui KB241165