Error Message: The Certificate Server Did Not Start: Unable to Initialize the Database Connection (241060)



The information in this article applies to:

  • Microsoft Windows NT Server 4.0
  • Microsoft Windows NT Server, Enterprise Edition 4.0

This article was previously published under Q241060

SYMPTOMS

After you install NTOP version of Certificate Server on incompatible ODBC versions, the Certificate Server Service does not start and the following error appears in the Application Log of the Event Viewer:
The Certificate Server did not start: unable to initialize the database connection for <Your CA Name>. The error code is oxffffffff.

CAUSE

This issue can occur if you install Internet Explorer 5 or MDAC 2.1 on your computer before you install Certificate Server.

RESOLUTION

To resolve this issue, follow these steps:
  1. Open the ODBC Data Sources Administrator in Control Panel.
  2. If you see a User DSN named CertSrv that is using the Access database, click Remove.
  3. Recreate the User DSN as a System DSN named CertSrv:
    1. On the System DSN tab, click Add.
    2. Click Microsoft Access Driver (*.mdb), and then click Finish.
    3. On the ODBC Microsoft Access Setup Page, type CertSrv for the Data Source Name.
    4. Under Database, click Select.
    5. Point to the %SystemRoot%\System32\CertLog\certsrv.mdb file, and then click OK.
    6. On the ODBC Microsoft Access Setup Page, click Advanced, and then configure the Default Authorization Login Name box to use Admin and no password.
  4. Use the Services tool in Control Panel to restart the Certificate Server Service.

MORE INFORMATION

There is an incompatibility between the NTOP installer and the ADO (Jet database) of MDAC 2.1 which shipped in Internet Explorer 5. This incompatibility causes Certificate Server to create a UserDSN for certsrv instead of the necessary SystemDSN.

Modification Type:MajorLast Reviewed:8/10/2001
Keywords:kbbug kbenv kberrmsg KB241060