Outlook Unable to View All Items in Microsoft Mail Shared Folder (240701)



The information in this article applies to:

  • Microsoft Outlook 97

This article was previously published under Q240701

SYMPTOMS

Not all items placed in Microsoft Mail Shared Folders by Microsoft Mail 3.5 users, can be seen by users of Outlook 97 or Outlook 98. Microsoft Mail, MS-DOS Mail, and Exchange Clients are not affected and get the entire contents of the folder.

CAUSE

The total number of items in each folder are recorded and maintained in two places. Each shared folder keeps its own total and is synchronized with the same field in the shared folder index file, Foldroot.idx. When these fields are not synchronized, only the Outlook client is affected. If the Foldroot.idx total is less than the <hex>.fld total, Outlook only displays the total indicated in the Foldroot.idx, ignoring the rest of the items in the folder.

RESOLUTION

Steps to Correct the Total

  1. Note the total number of items in the folder displayed at the bottom left corner of Outlook.
  2. Using Outlook, save a new post to the affected folder. Make sure you can read the new post. The total items will not change.
  3. Quit Outlook, and log off. Start Outlook again, and view that same folder. You should now see the complete listing of messages in the folder and the total displayed will have incremented by the number of missing items plus 1.
For example, The MS-DOS or Exchange client displays 100 items in folder X. Outlook displays 87 items in folder X. Save a new post, quit Outlook, and log off. Start Outlook again. View the folder X. The number of items should now be 101.

87 + 13 (missing) + 1 (new) = 101.

Modification Type:MajorLast Reviewed:10/26/2000
Keywords:kbprb KB240701