You receive an "Internal error 2336" error message that is caused by possible file damage when you install Office 2000 (240335)



The information in this article applies to:

  • Microsoft Office 2000 Premium
  • Microsoft Office 2000 Professoinal
  • Microsoft Office 2000 Standard
  • Microsoft Office 2000 Small Business
  • Microsoft Office 2000 Developer
  • Microsoft Access 2000
  • Microsoft Excel 2000
  • Microsoft FrontPage 2000
  • Microsoft Outlook 2000
  • Microsoft PowerPoint 2000
  • Microsoft Word 2000

This article was previously published under Q240335
WARNING:This information is preliminary and has not been confirmed or tested by Microsoft. Use only with discretion.

SYMPTOMS

When you install Office 2000, the following error message may appear:
Internal error 2336: Please Contact Product Support for assistance.
Also, if you create a verbose log file, you may see text similar to the following if you search the log file for 2336:
MSI (c) (2D:D1): Executing op:
FileCopy(SourceName=BD18199_.WMF,DestName=BD18199_.WMF,Attributes=8193,FileSize=3132,,,InstallMode=58982400,PerTick=32768,IsCompressed=0,,VerifyMedia=1,,) MSI (c) (2D:D1): File: c:\Program Files\Common Files\Microsoft Shared\Clipart\autoshap\BD18199_.WMF; Overwrite; Existing file is unversioned and unmodified
InstallFiles: Copying file: BD18199_.WMF (3132bytes) to c:\Program Files\Common Files\Microsoft Shared\Clipart\autoshap\
MSI (c) (2D:D1): Note: 1: 2336 2: 82 3: c:\Config.Msi\
Internal Error 2336: Please contact product support for assistance.
Action ended 20:19:49: InstallExecute. Return value 3.
For additional information about interpreting log files, click the following article number to view the article in the Microsoft Knowledge Base:

237957 How to use an Office 2000 Setup log file to troubleshoot Setup problems

CAUSE

This error message may appear if one or more files being replaced by Setup is damaged, or if there are problems with the \Config.msi folder on your hard disk. In the scenario that generated the log file text in the "Symptoms" section, the possible damage was in the Bd18199_.wmf file.

WORKAROUND

To work around this issue, follow these steps:
  1. Click OK to the error message, if it is still displayed. At this point, the Setup rollback process should start and restore your computer to its pre-Setup configuration. For additional information about the Setup rollback process, click the article number below to view the article in the Microsoft Knowledge Base:

    224140 OFF2000: Cannot Use Automatic Recovery During Detect and Repair

  2. Locate the Config.msi folder listed in your Setup log file.

    NOTE: This is a hidden system folder. You may have to configure Microsoft Windows to show all files.
  3. Rename this folder to Config.old. The next steps are sample steps that may need to be modified to fit your particular situation. They depend on the file that was being copied when Setup failed. In the situation that created the log file text in the "Symptoms" section, the .wmf file being copied was possibly damaged. So the focus was on the .wmf files in the c:\Program Files\Common Files\Microsoft Shared\Clipart\autoshap\ folder.

  4. Create a folder called Autoshap Backup folder on the root of your C: drive.
  5. Locate the c:\Program Files\Common Files\Microsoft Shared\Clipart\autoshap\ folder.
  6. Move all of the files in this folder to the Autoshap Backup folder. The c:\Program Files\Common Files\Microsoft Shared\Clipart\autoshap\ folder should now be empty.
  7. Re-run Office Setup.
  8. If Setup is successful, you can then delete the Config.old and Autoshap Backup folders that you created in the preceding steps.

REFERENCES

For more articles about how to troubleshoot specific errors in Office Setup: For more articles with general information about how to troubleshoot Office errors:

Modification Type:MinorLast Reviewed:10/13/2006
Keywords:kbtshoot kberrmsg kbprb kbsetup KB240335