XIMS: Mail Queue Grows Excessively During Heavy Message Traffic (240312)



The information in this article applies to:

  • Microsoft Commercial Internet System 1.0
  • Microsoft Commercial Internet System 2.0
  • Microsoft Commercial Internet System 2.5

This article was previously published under Q240312

SYMPTOMS

If an individual mailbox receives a large number of messages in a short period of time, the messages may begin to accumulate in the delivery queue and numerous .ltr files that contain the following text may begin to accumulate in the associated folder on the server's hard disk:
The process cannot access the file because it is being used by another process.
The number of .ltr files in the folder may increase very rapidly, causing large amounts of disk space to be used on the server.

This problem has been known to occur with the administrator's mailbox when a server is not functioning properly and messages cannot be delivered to recipients on the server. Under these conditions, a large number of non-delivery reports (NDRs) may be sent to the administrator's mailbox in a short period of time.

CAUSE

When a mailbox receives a message, Microsoft Commercial Internet System (MCIS) starts a delivery thread and subsequently locks the index file. If MCIS attempts to deliver another message to the same mailbox before the index file has been released, the message is placed in the queue and an .ltr file that contains the above text is created. If the index file is not released in a timely manner and the mailbox receives additional messages, numerous .ltr files are created. Furthermore, if the time-out and retry settings are not configured appropriately, the server may attempt to deliver the same message numerous times, causing multiple .ltr files to be created for the same message.

Each time a server is unable to deliver a message, an NDR is sent to the administrator's mailbox. If a large number of messages are sent to a server that is not functioning properly and the server attempts to deliver individual messages numerous times, a large number of NDRs are sent to the administrator's mailbox in a short period of time. If MCIS attempts to deliver an NDR or any other message to the administrator's mailbox while the index file is locked, an .ltr file is created.

WORKAROUND

You may be able to prevent this behavior from occurring by modifying the time-out and retry settings on the server. The server should be configured to time out or retry after a longer period of time and to retry less frequently. By default, the server retries after 60 minutes and retries a total of 48 times.

Modification Type:MinorLast Reviewed:4/28/2005
Keywords:kbprb KB240312